Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13242 closed Bug (invalid)

Helper line disappears when dragging image without caption (with enhanced image)

Reported by: tomm Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When you try to reposition an image with the enhanced image plugin without a caption you get no indication of where in the webpage the image will be dropped if you let go of your mouse.

If you do this with an image with a caption the helper line tells your where your image will be moved if you let go of the mousebutton.

Steps to reproduce:

  1. Go to http://ckeditor.com/demo#widgets and find the enhanced image demo
  1. Drag the image using the cross in the top left corner and you will see the helper line indicate where the image will be positioned if you let go of the mousebutton
  1. Edit the image and deselect "Captioned image"
  1. Now try dragging the image and you will see that the helper line is gone and its really difficult to see where your image will be positioned

Browser/OS:

Firefox 37.0.2 and Chrome 42.0.2311.135 on OSX 10.10.3.

Change History (2)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: newclosed

Dragging of inline widgets (like image without a caption) is handled by the browsers. We implemented dragging of block widgets because it needs to behave differently (you can drop only between blocks) and because it was possible. Reimplementing dragging of inline content is nearly impossible and hence we need to base on browsers native behaviours. I admit that the caret rendered by browsers is not that visible as our line, but with the currently available native APIs we are not able to improve. Additionally, we should not be forced to override every single native behaviour. This is neither good for the code size nor for consistency with the rest of the OS in which user works. Therefore, I don't think we should ever touch this particular behaviour.

comment:2 Changed 4 years ago by Piotrek Koszuliński

I closed this ticket as invalid but it's more like "can't fix" and "won't fix" together.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy