Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13290 closed Bug (duplicate)

[Chrome] Format not applied if format selected then quickly select the text area.

Reported by: TIMBERings Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

In Chrome, if a format is selected then a user quickly starts typing after clicking the text area, the format selected is removed. A video is attached.

Steps to Reproduce

  • Go to the demo: http://ckeditor.com/demo
  • Clear the existing text
  • Click off focus
  • Click Bold (or some format)
  • Click the text area quickly
  • Start typing

Expected Results Any selected format is applied

Actual Results The selected format is removed

Attachments (1)

format.mov (650.3 KB) - added by TIMBERings 4 years ago.
Format removed

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by TIMBERings

Attachment: format.mov added

Format removed

comment:1 Changed 4 years ago by Jakub Ś

Keywords: chrome format removed
Resolution: duplicate
Status: newclosed

When you click bold button, it gets enabled and focus goes to editor. After you click bold and start typing (even very fast) everything works as expected.

I have been able to reproduce this "problem" (in every browser) but I can't understand what is the real use case here if any. If editor puts focus in content area automatically then there really is no need to extra click it. By doing that you are getting into already repoted problem - #12634.

Taking above into account I'm closing this ticket as duplicate of #12634

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 4 years ago by TIMBERings

It's not my product, so I'm not going to fight it. But think of it from an end user's perspective. 99% of them are going to click the box to type whether clicking a format gives you focus or not.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy