Opened 4 years ago

Closed 23 months ago

#13315 closed Bug (invalid)

CKEditor object in debug mode doesn't load correctly.

Reported by: giorgio Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0 Beta
Keywords: IBM Cc: IRINAURU@…, giorgio, satya_minnekanti@…, chrisgui@…

Description

Using the CKEditor in debug mode ( ?x-ckeditor-debug=true ) , when the CKEditor loads, i'm getting errors in the console, regarding some methods missing(e.g. the CKEDITOR.on method).

I used to this simple html page to load the editor :

<!DOCTYPE html> <html> <head>

<title>Source defect CKEditor Sample</title> <meta charset="utf-8"> <script src="../ckeditor.js"></script>

</head> <body>

<p>

<label for="editor1">

Editor 1:</label>

<textarea cols="80" id="editor1" name="editor1" rows="10">

&lt;p&gt;This is some &lt;strong&gt;sample text&lt;/strong&gt;. You are using &lt;a href="http://ckeditor.com/"&gt;CKEditor&lt;/a&gt;.&lt;/p&gt;

</textarea> <script>

CKEDITOR.replace( 'editor1' );

</script>

</p>

</body> </html>

Change History (4)

comment:1 Changed 4 years ago by giorgio

Don't pay attention to that parameter that i've mentioned... i've just meant that we're using the ckeditor in debug mode.

Sorry for the inconvenience.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Status: newpending

What do you mean by "debug mode"? There are only the source mode and build mode. Do you mean the source mode? If so, we would need a sample on which this error can be reproduce, because the HTML you pasted is very standard and it works for us.

comment:3 Changed 4 years ago by giorgio

I've meant in source mode, sorry for the incomprehension.

I was using the CKEDITOR.on method right after loading the CKEDITOR object using the loader, and apparently the event module wasn't loaded still.

I moved the call of the CKEDITOR.on elsewhere, to give time at the module to be loaded, and it works fine now.

I guess you can close this ticket.

Sorry for the mistake.

comment:4 Changed 23 months ago by Jakub Ś

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy