Opened 4 years ago

Closed 4 years ago

#13344 closed Bug (fixed)

It is possible to remove/change editor contents in readonly mode

Reported by: Jakub Ś Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.4.8
Component: General Version: 4.4.2
Keywords: Blink Webkit Support Cc:

Description

Issue reported on our support channel.

I have a use case where CKEditor is opened in readonly based on user’s privilege however I am able to merge paragraphs or delete content even when readonly is set to true.

  1. In first case I select two paragraphs and press delete key. The selected content gets deleted.
  1. In second case I try to place cursor at start of second paragraph and press backspace. The paragraphs get merged.

Let me know if there is any workaround to fix it.

Attachments (1)

2015-06-01_1147.swf (456.3 KB) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by Jakub Ś

Attachment: 2015-06-01_1147.swf added

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed

comment:2 Changed 4 years ago by Piotrek Koszuliński

I guess it's one of the fixes for #9998. It should check if the editor is in readonly mode and I guess it doesn't.

comment:3 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.4.8

comment:4 Changed 4 years ago by Tade0

Owner: set to Tade0
Status: confirmedreview

Changes in branch:t/13344.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed
  • Tests are missing (only automated ones in this case - tests/editable/keystrokes/delbackspacequirks/*.
  • Your branch is anchored to some old commit. It should diverge from master.

comment:6 Changed 4 years ago by Tade0

Status: review_failedreview

Added tests.

comment:7 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed

Fixed on master with git:e857553.

I made two changes:

  • Made sure that read-only mode is disabled when a test fail.
  • Added a manual test, because I realised that I'm not 100% sure that we fixed the reported TC :D. There could be some other listener somewhere which might be changing the content.
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy