Opened 10 years ago

Closed 9 years ago

#1338 closed Bug (worksforme)

Avoid hardcoding border width for Gecko browsers

Reported by: Matthias Miller Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: HasPatch Pending Cc:

Description

Gecko browsers assume that xEditingArea has a 1-pixel border. Changing this to be determined dynamically would allow greater customizability in skins (for example, a borderless editor or an editor with a beveled border).

Attachments (1)

fckeditor.html.patch (534 bytes) - added by Matthias Miller 10 years ago.

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Matthias Miller

Attachment: fckeditor.html.patch added

comment:1 Changed 10 years ago by Matthias Miller

I forgot to mention: To test, I enabled the AutoGrow plugin and changed the default skin to use a different border width for xEditingArea.

comment:2 Changed 10 years ago by Matthias Miller

Is there any chance of getting this patch committed?

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: HasPatch added

Marking this ticket for review.

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

I understand the reasoning, but the problem is that even without this patch I'm not able to see any bug, so I can't tell what is fixing.

Could you please provide a simple testcase or detailed instructions to see the problem (I've tried setting 0px and 10px as the border for the xEditingArea element and it seems to work fine)

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Pending added

comment:6 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: worksforme
Status: newclosed

Expired.

Please reopen if you can provide the steps in order to fully test the bug and the patch.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy