Opened 3 years ago

Closed 3 years ago

#13460 closed Bug (fixed)

[IE8] Broken copying of inline widgets

Reported by: Olek Nowodziński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.5.2
Component: Core : Pasting Version: 4.3 Beta
Keywords: Cc:

Description

clipboard/manual/paste

  1. Visit http://tests.ckeditor.dev:10450/tests/plugins/clipboard/manual/paste
  2. Copy and paste an inline widget.

It works.

widget/manual/inline

  1. Visit http://tests.ckeditor.dev:10450/tests/plugins/widget/manual/inline
  2. Copy and paste an inline widget.

It doesn't work. It looks like paste bin is displayed (slight scroll) but nothing is pasted.


The difference between tests might be the key to the mystery.

Attachments (2)

ie8Clipboard:widget:manual:inline.mp4 (592.9 KB) - added by Olek Nowodziński 3 years ago.
ie8Cliboard:manual:paste.mp4 (1.5 MB) - added by Olek Nowodziński 3 years ago.

Change History (9)

Changed 3 years ago by Olek Nowodziński

Changed 3 years ago by Olek Nowodziński

comment:1 Changed 3 years ago by Piotrek Koszuliński

Status: newconfirmed
Summary: [IE8] Broken pasting of inline widgets[IE8] Broken copying of inline widgets

It's copy what's broken. The copybin gets into clipboard and that makes the problem... But it's very very weird that it happens in this sample and no where else ;/

comment:2 Changed 3 years ago by Olek Nowodziński

  1. Fact: It's because of allowedContent: true added to the test in git:eb8898c888.
  2. Fact: I bisected and it looks like... it's not a regression. It's never been working.
Last edited 3 years ago by Olek Nowodziński (previous) (diff)

comment:3 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.1

Ha! I remember now. I already found this bug long time ago and yes - it never worked :D.

comment:4 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.1

Or we can try to fix it. Even by regexp.

comment:5 Changed 3 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: confirmedassigned

comment:6 Changed 3 years ago by Olek Nowodziński

Status: assignedreview

Changes in branch:t/13460.

comment:7 Changed 3 years ago by Piotrek Koszuliński

Resolution: fixed
Status: reviewclosed
Version: 4.3 Beta

Fixed on master with git:e561d84.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy