Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13461 closed Bug (duplicate)

Inline CKEditor not working inside Foundation Tabs using Chrome

Reported by: Erwin Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

CHROME issue !!

I'm using CKEditor inline with the jquery adapter inside Foundation tabs. In the first tab which is open CKEditor works fine. In the second tab CKEditor does show the toolbar, but I cannot edit or add any text. And I cannot use the toolbar.

This works fine in Safari and FF (both tested), but does NOT work in Chrome. My Chrome version: 43.0.2357.130 (64-bit)

I've set up an example page at: http://jsfiddle.net/u0v9vxgo/12/

Is this a CKEditor issue? Suggestions how to solve it?

Attachments (1)

ckeditor-chrome-issue.png (78.9 KB) - added by Erwin 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Erwin

Attachment: ckeditor-chrome-issue.png added

comment:1 Changed 4 years ago by Piotrek Koszuliński

Keywords: Foundation tabs chrome removed
Resolution: duplicate
Status: newclosed
Version: 4.4.7

The editor that you see in the second tab is in read only mode. Most likely caused by #9814. The workaround is to call editor.setReadOnly( false ) when tab is opened.

comment:2 Changed 4 years ago by Erwin

I confirm that this is the solution:

  $(this).ckeditorGet().setReadOnly(false);

Thanks Reinmar!

Last edited 4 years ago by Erwin (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy