Opened 3 years ago

Closed 3 years ago

#13523 closed Bug (invalid)

Anomaly with the CKEditor Mathjax plugin on Firefox

Reported by: João Palhoto Matos Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I have been able to reproduce this with the latest Firefox both on Linux and Windows but not with Chrome, Opera or IE. It does not concern ckeditor in inline editing mode so I cannot reproduce it in your demo page. I have reproduced it both with CKEditor 4.4.8 and 4.5.1.

To reproduce go https://sem2.math.tecnico.ulisboa.pt/cketest/ with credentials

cke

cke

ignoring any certificate issues.

The text on the central part of the page contains 2 mathematical formulas. One was created directly (the integral), the other (the quadratic formula example) with the CKEditor MathJax plugin. Both should be visible.

Open the editing area by pressing the Edit button. You get a classic (not inline) CKEditor editing area. The anomaly is the plugin created formula not being visible. You can check that it is there going to Source mode.

Delete everything from the editing area and introduce a mathematical formula using the MathJax plugin. Everything should work normally. Save your text and close the editing area. Reload the and open the editing area again. The formula is no longer visible in WYSIWYG mode.

Repeat with Chrome, Opera or IE. You should see the plugin created formulas when expected without anomalies.

Change History (2)

comment:1 Changed 3 years ago by João Palhoto Matos

Please ignore the observation about inline editing mode. Nevertheless, in the demo page for mathematical formulas, I am not able to test the problem.

comment:2 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.1

When I open your page I'm getting a lot of security exceptions in Firebug console.

When I click edit button I can only see O integral \(\int_a^b f(x)\, dx\) é } and nothing else. Looks like MathJax is not working.

When looking at the Firebug NET tab I can see (font and MathJax.js) marked as aborted.

The message for font is (taken from Chrome):

sem2.math.tecnico.ulisboa.pt

Font from origin 'https://math.tecnico.ulisboa.pt' has been blocked from loading by Cross-Origin Resource Sharing policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://sem2.math.tecnico.ulisboa.pt' is therefore not allowed access.

It is possible that same goes for MathJax.js.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy