Opened 4 years ago

Closed 3 years ago

#13527 closed Bug (invalid)

System does not copy paste MS Visual Studio formatting into CKEditor

Reported by: david.zhang Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.1
Keywords: Cc:

Description

When pasting from ,MS Visual Studio,documents some of the formatting is lost.

Steps to reproduce:

1:use MS Visual Studio.

3:CTRL+C come codes and CTRL+V , past it to CKEditor.

Expected Result:

They would be pasted without any styling but all the text are there

Actual Result: The text style is not pasted into CKEditor at all.

Attachments (2)

vs2013.png (257.0 KB) - added by david.zhang 4 years ago.
MS Visual Studio
VS.png (1.6 MB) - added by david.zhang 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by david.zhang

Attachment: vs2013.png added

MS Visual Studio

Changed 4 years ago by david.zhang

Attachment: VS.png added

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

The First problem is that Browsers don't see VS formatting the same way as VS does. For example there is no indent style. Instead there are   which you can see.

You can't just copy the code from IDE and expect it will look 1:1. You would need some extra plugin for it. There is nothing we can do in this case.


Second Problem is that only IE sees styles from VS. All other browsers don't. Again nothing we can do here.


I have checked your images and I believe the problem is also in your application in step 5 when you publish the post what equals to saving content on server-side. I think you are encoding it one time to many thus you can see such result.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy