Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13539 closed Bug (invalid)

CKEditor created from CKBuilder don't load

Reported by: Pnina Alon Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hello I wanted to create a custom ckeditor - Full Version with UploadImage plugin , and when i downloaded it and installed it on server - it doesn't load the editor , and when i tried to see the example on my local computer - it also doesn't work , and i don't know what to do.

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.1

The http://ckeditor.com/addon/imgupload plugin is a third party plugin not supported by CKSource.

When looking at its website I can see it is not compatible with latest CKEditor version so I'm not sure if it will work.

Please make sure that you have configured this plugin according to what was written in /ckeditor/plugins/imageupload/README.rst. If you have configured plugin properly and you are still getting problems, please report them to plugin author.

Last edited 3 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 3 years ago by Jakub Ś

The problem is caused by imageupload plugin. You need to configure it properly and if it doesn't work, please contact plugin author.

comment:3 Changed 3 years ago by Jakub Ś

@pninaA - I just wanted to make few things clear.

You have written about imageupload plugin while I have written about imgupload. Could you tell me which on you use and which one you had in mind?

imgupload - initially there is error thrown. As I have written in comment:1, please try configuring this plugin and if it doesn't work, please report this problem to plugin author.

imageupload - displays only warning in console (e.g. Firebug Console). It is possible however that you have installed this plugin manually. If that is the case, you need to know that this plugin requires 4 others which you have to install as well. If you miss any of these plugins, error will be thrown and CKEditor will now show.
The quickest way to install this plugin is to use http://ckeditor.com/builder. It will add required plugins automatically for you. If you however want to do it manually (I in fact did it that way). Please check Firebug console for missing plugin, download and install it (repeat 3 more times :))

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy