Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13550 closed Bug (wontfix)

[IE 11] Clicking white space does not unhighlight selected text

Reported by: bin.qiao Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I'm using the latest version with IE 11 on Windows, having following issue.

  1. Type "Test" in editor
  2. Select "Test" to highlight it
  3. Click at the white space UNDER the selected text

Expected result: Selected text is no longer highlighted Actual result: Selected text is still highlighted

This cannot be reproduce with FF browser. I'm able to reproduce this using the CKEditor demo site with IE 11.

Change History (2)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed
Version: 4.5.1

Thanks for the report. Unfortunately, this bug cannot be fixed by us in an acceptable manner. All IEs do poor job when it comes to handling clicking below the <body> so we have some special solutions for it. And while on IE8-10 we've been able to hack it rather well, on IE11 an ugly hack needed to be implemented because necessary APIs were removed (we've been using legacy APIs to hack it). The behaviour that you can see is a result of that hack.

The workarounds I can see are:

  1. Use the divarea plugin instead of the wysiwygarea.
  2. Styling body so it expands automatically.

Related issues:

comment:2 Changed 4 years ago by Jakub Ś

As @Reinmar has already mentioned this is happening due to small body in content area e.g. http://dev.ckeditor.com/ticket/10169#comment:1.

Another workaround which might, work well for iframed editor with some default size is using min-height as explained briefly here - http://dev.ckeditor.com/ticket/10169#comment:5.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy