Opened 4 years ago

Closed 4 years ago

#13576 closed Bug (invalid)

Extra <li> tag is getting added automatically when ever i copy and paste

Reported by: Sibasish palo Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Whenever i try to copy and paste the following piece of code <ol>

<ol>

<li>Item1 </li> <li>Item2 </li>

</ol>

</ol>

it always adds a <li> tag in between as follows:

<ol>

<li>

<ol>

<li>Item1 </li> <li>Item2 </li>

</ol>

</li> </ol>

Above code is appending a extra <li> tag because of that an extra numbered list is automatically coming at the starting like as follow:

expected:


1.item1 2.item2

actual result:


1.

1.item1 2.item2

Change History (5)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Status: newpending
Version: 4.3.3

I can't reproduce it on http://ckeditor.com/demo.

Please describe:

  1. On what browser it happens.
  2. The exact steps to reproduce it. What contents do we need, what to select, what to copy and where to paste it.

comment:2 Changed 4 years ago by Sibasish palo

Hi Reinmar,

Thank you for the response.I tried on the above link provided by you and the issue is reproducible.

Steps to reproduce


1--open this link http://ckeditor.com/demo.

2--remove everything from the editor and paste the following code by selecting source mode

<ol>

<ol>

<li>Item1 </li> <li>Item2 </li>

</ol>

</ol>

3--After pasting the above code in source mode switch to normal mode.

4--You will notice an extra Numbered list item will added automatically.

Please let me know whether you are able to reproduce the issue or not and please suggest me a solution for the same.

Regards- Sibasish

Last edited 4 years ago by Sibasish palo (previous) (diff)

comment:3 Changed 4 years ago by Piotrek Koszuliński

But that source is incorrect. There are two nested <ol> elements. So I don't even need to check.

comment:4 Changed 4 years ago by Sibasish palo

Hi, can you suggest me CSS code to remove the extra <ol> tag,whenever there is an extra <ol> tag

<ol>

<ol>

<li>Item1 </li> <li>Item2 </li>

</ol>

</ol>

comment:5 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

You simply need to fix this HTML manually or using some tool like HTMLTidy. It's not CKEditor's job to do so.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy