Opened 4 years ago

Closed 3 years ago

#13577 closed Bug (worksforme)

[Edge] Copying a widget scrolls the viewport

Reported by: Piotrek Koszuliński Owned by: Szymon Cofalik
Priority: Normal Milestone:
Component: Core : Pasting Version: 4.5.0
Keywords: Edge Cc:

Description

  1. Open http://tests.ckeditor.dev:1030/tests/plugins/clipboard/manual/paste
  2. Focus a widget.
  3. Press CTRL+C or the paste button.

The viewport is scrolled. It happens in framed and inline editors.

Change History (18)

comment:1 Changed 4 years ago by Szymon Cofalik

Owner: set to Szymon Cofalik
Status: newassigned

comment:2 Changed 4 years ago by Szymon Cofalik

Pushed branch:t/13577b with a fix and a note in manual test.

comment:3 Changed 4 years ago by Szymon Cofalik

Status: assignedreview

comment:4 Changed 4 years ago by Piotrek Koszuliński

Status: reviewreview_failed

I rebased the branch and pushed one micro commit there.

A things I would like to know are:

  • why the hack for IE8 can't be used on Edge too?
  • if we can't use the same hack, then can we use the hack from Edge on IE8?
  • why do we need to scroll again after the pastebin is removed?

I'm giving R- for not explained complexity, so a possible overcomplication.

comment:5 Changed 4 years ago by Szymon Cofalik

Status: review_failedassigned

We have to have seperate hacks because IE8 is not compatible with modern browsers and does not use window.scrollY / window.scrollTop() but use document.scrollTop instead. On Edge document.scrollTop is 0 even though the content is scrolled. window.scrollY works correctly.

why do we need to scroll again after the pastebin is removed?

Because Edge scrolls down after focusing a widget. I thought it scrolls down after removing copybin but there is probably something wrong in widget focusing, so I am investigating this now.

comment:6 Changed 4 years ago by Szymon Cofalik

Status: assignedreview

It seems that there is something strange happening on Edge. When copybinContainer is not appended to editable, hiding selection does not cause Edge to scroll the viewport. However, when copybinContainer is appended, scroll happens. It was enough to prepend either copybinContainer or hidden selection container.

copybinContainer prepending is less intrusive because copybinContainer exists only for 100ms and is contained within widget copying, while selection hiding is used all over editor.

New solution is available on branch:t/13577c

comment:7 Changed 4 years ago by Olek Nowodziński

Milestone: CKEditor 4.5.3CKEditor 4.5.4

comment:8 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.4CKEditor 4.5.5

comment:9 Changed 4 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.5CKEditor 4.5.6

comment:10 Changed 4 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:11 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7CKEditor 4.5.8

comment:12 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8CKEditor 4.5.9

comment:13 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9CKEditor 4.5.10

comment:14 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.10CKEditor 4.5.11

Moving tickets to the next milestone.

comment:15 Changed 3 years ago by Jakub Ś

There is similar ticket #14742

comment:16 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.11CKEditor 4.6.1

comment:17 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.6.2

comment:18 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.2
Resolution: worksforme
Status: reviewclosed

It's been a while, and looks like Edge team has fixed this bug, as it's no longer reproducible at our latest master.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy