Opened 4 years ago

Closed 4 years ago

#13578 closed Bug (invalid)

[IE11] Paste from word in IE11 displays red flag and replaces some text with '< >'

Reported by: oliverh Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When pasting text with 3 levels of ordered lists (numeric, alpha, and roman numerals) some issues occure:

  • A red flag appears as part of the first numeric list iteam
  • Some text is replaced by '< >'

Steps to reproduce:

  1. Copy the text from the attached file
  2. Use the "paste from word" functionality to paste into CKEditor

Attached files:

  • screenshot showing issue
  • Word document containing content that fails 'paste from word'

Spec details

  • Browser: IE11 (works perfectly in Chrome)
  • OS: Windows 8.1
  • CKEditor version: 4.4.6
  • Occurs on demo site: yes

Attachments (5)

CKEditor failing screenshot.jpg (138.7 KB) - added by oliverh 4 years ago.
CKEditor Failing example.docx (12.7 KB) - added by oliverh 4 years ago.
CKEditor Failing example 2.docx (14.3 KB) - added by oliverh 4 years ago.
CKEditor Failing example 2.jpg (188.0 KB) - added by oliverh 4 years ago.
CKEditor in IE11 set to IE 9 or 10.jpg (331.4 KB) - added by oliverh 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by oliverh

Changed 4 years ago by oliverh

comment:1 Changed 4 years ago by oliverh

Summary: Paste from word in IE11 displays red flag and replaces some text with '< >'[IE11] Paste from word in IE11 displays red flag and replaces some text with '< >'

comment:2 Changed 4 years ago by oliverh

Latest release has partly fixed this issue but issue still around:

  • A red flag appears as part of the first numeric list item
  • not correctly capturing the ordered lists(first line of list item was converted into list item with content plus an empty list item)
Last edited 4 years ago by oliverh (previous) (diff)

comment:3 Changed 4 years ago by oliverh

Update on issue from further testing:

The latest release has fixed the issue of "missing text"/"text being replaced by < >"

Issues remaining:

  1. A red flag appears as part of the first numeric list item
  2. <new> Error message appears when 'paste from word' is used with the text from the attached document(CKEditor Failing example 2.docx): "It was not possible to clean up the pasted data due to an internal error"
  3. <new> An extra numbered list is created resulting in two 1. showing up when pasting data from attached document (CKEditor Failing example 2.docx) (example screenshot attached: CKEditor Failing example 2.jpeg)
Last edited 4 years ago by oliverh (previous) (diff)

Changed 4 years ago by oliverh

Changed 4 years ago by oliverh

Changed 4 years ago by oliverh

comment:4 Changed 4 years ago by oliverh

from further investigation: if we use IE 11 in IE9 or IE10 mode, issue 3 from the previous comment does not seem to occur.

comment:5 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.1

Please have a look at the HTML code that IE11 sees:

<ol style="list-style-type: decimal; direction: ltr;">
<li style='color: rgb(0, 0, 0); font-family: "Book Antiqua","serif"; font-size: 11pt; font-style: normal; font-weight: normal;'><p style='color: rgb(0, 0, 0); line-height: normal; font-family: "Calibri","sans-serif"; font-size: 11pt; font-style: normal; font-weight: normal; margin-top: 12pt; margin-bottom: 0pt; mso-list: l1 level1 lfo1; tab-stops: 1.0cm;'>
<a name="_Ref332021279">
<span lang="EN-AU" style='font-family: "Book Antiqua","serif"; mso-bidi-font-size: 10.0pt; mso-fareast-font-family: "Times New Roman"; mso-bidi-font-family: "Times New Roman"; mso-ansi-language: EN-AU;'>The effluent treatment system and disposal system shall be operated and
maintained to ensure compliance with the conditions of this consent. Operation
and maintenance includes:
</span>
</a>
</p>
</li>
</ol>

That red flag that you see in editor is anchor placeholder (they have to be represented somehow) and this is perfectly fine. CKEditor pasted HTML it gets (with some processing of course).

You need to correct your word file, there is editor error here.

NOTE: Yes, The <> were fixed in CKE 4.5.2.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy