Opened 4 years ago

Closed 4 years ago

#13613 closed Bug (duplicate)

[Edge] Typing in an empty editor creates DIV tags rather than P tags

Reported by: Jie Lu Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Go to http://nightly.ckeditor.com/15-07-31-06-08/standard/samples/
  2. Clear the contents of the editor (make sure it's completely empty).
  3. Type a few paragraphs.
  4. Note that MagicLine shows up between every line.
  5. Switch to source view. Note that each paragraph is a DIV tag.
  6. Switch to wysiwyg view and then back to source view. Note that the paragraphs are now P tags.

Expected result

Paragraphs are wrapped in P tags as the user enters text.

Actual result

Paragraphs are wrapped in DIV tags as the user enter text. DIV tags are converted to P tags when the content is reloaded.

Other details (browser, OS, CKEditor version, installed plugins)

Edge Browser in Windows 10

Change History (1)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Resolution: duplicate
Status: newclosed
Version: 4.5.1

This is a DUP of #13142 and this bug is caused by Edge's bug unfortunately. We've been trying to work around it, but it's very complicated to do it right. We expect to have some solution for it in 4.5.3 though.

PS. Please note that we do not recommend using Edge at the moment. In our opinion this browser is still too buggy and unstable.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy