Opened 4 years ago

Closed 4 years ago

#13616 closed Bug (fixed)

List items are lost when pasting from Word document

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 4.3
Keywords: Cc:

Description

Steps to reproduce

Paste the attached document from MS Word 2010 into CKEditor in IE11

Expected result

Three list items should be pasted

Actual result

<p>Degree &deg;</p>

<p>Angle &nbsp;&ang;</p>

<p>Pi &pi;</p>

<ul>
	<li>&lt; &gt;<!--   -->&lt; &gt;<!--   -->
	<p>Baz</p>
	</li>
</ul>

<p>&nbsp;</p>

Other details (browser, OS, CKEditor version, installed plugins)

Tested on std-all with the following setup:

<!DOCTYPE html>
<html>
<head>
	<meta charset="utf-8">
	<title>CKEditor</title>
	<script src="//cdn.ckeditor.com/4.5.1/standard-all/ckeditor.js"></script>
</head>
<body>
<textarea name="editor1"></textarea>
<script>
	CKEDITOR.replace( 'editor1', {
		pasteFromWordRemoveFontStyles: false,
		pasteFromWordRemoveStyles: false
	} );
</script>
</body>
</html>

Did not try other browsers.

Attachments (1)

13616.docx (14.0 KB) - added by Wiktor Walc 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Wiktor Walc

Attachment: 13616.docx added

comment:1 Changed 4 years ago by Wiktor Walc

Status: newconfirmed
Version: 4.5.14.3

comment:2 Changed 4 years ago by Wiktor Walc

Component: GeneralPlugin : Paste from Word

comment:3 Changed 4 years ago by Piotrek Koszuliński

Most likely a DUP of one of the tickets mentioned in #13590. But since we had a problem recently with a cases looking similar but being different, let's keep this open and have it tested in #13590.

comment:4 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This issue has been fixed in CKEditor 4.5.2. #13590 will contain a test for it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy