Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#13699 closed Bug (invalid)

CKEditor crashes when user conected through SSL - Uncaught TypeError: c.addRules is not a function

Reported by: Prasanta Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.3
Keywords: Cc:

Description

We have a intranet site where CKEditor is working as expected. The issue we saw yesterday that when a user a remote user tries to use the site through SSL (Remote user portal), CKEditor crashes with error message "Uncaught TypeError: c.addRules is not a function". Any idea?

Attachments (3)

errorpage.png (74.6 KB) - added by Prasanta 4 years ago.
As you can see the CKEditor is not visible on this one and error message.
validpage.png (85.5 KB) - added by Prasanta 4 years ago.
There is no issue when using without ssl
ckeditor.js (545.2 KB) - added by Yücel 3 years ago.
Working edited ckeditor.js

Download all attachments as: .zip

Change History (15)

Changed 4 years ago by Prasanta

Attachment: errorpage.png added

As you can see the CKEditor is not visible on this one and error message.

Changed 4 years ago by Prasanta

Attachment: validpage.png added

There is no issue when using without ssl

comment:1 Changed 4 years ago by Prasanta

I have tried on IE9, IE10, IE11, chrome and Firefox. same result..

comment:2 Changed 4 years ago by Piotrek Koszuliński

Status: newpending

I've got no idea what could go wring here, because addRules() is a method on a filter and there's nothing related to SOP in this case. I can see you use a minified version, so all plugins are in a one file, so it does not really make sense.

I'm afraid you need to debug a bit yourself, because everything works fine here: https://cdn.ckeditor.com/4.5.3/standard/samples/. Please make sure that you uploaded CKEditor package correctly.

comment:3 Changed 4 years ago by Markus

Did you come to any solution for this problem? We have the same error message when accessing the site through the "Junos Pulse Secure Access Service" (A remote user portal). Accessing the site directly works without problems.

comment:4 Changed 4 years ago by Piotrek Koszuliński

We're still waiting for a TC that we could reproduce. So far everything worked for us perfectly. So if you can prepare some setup that fails, we'll be very grateful.

comment:5 Changed 3 years ago by avdhut sonpethkar

I am also facing the same issue ? has anyone found any resolution.

comment:6 Changed 3 years ago by Jakub Ś

@avdhut, please read above comments. We are not able to reproduce this problem on our side. If you can provide test case steps to reproduce it we would be grateful.

comment:7 Changed 3 years ago by avdhut sonpethkar

The issue occurs when we are using SSL VPN to connect and gain access to application. Otherwise in local network it works fine.

comment:8 Changed 3 years ago by Yücel

Greetings, I have been fighting with this issue for a couple of days. I have overcome the problem by manipulating ckeditor.js a little. Easiest solution was to change the way CKEDITOR.htmlParser.filter is called (addRules function is called for this object). Junos vpn changes this occurences to DanaGetFilter(document.htmlParser) and so on, we need to call it in a way so that vpn won't recognize it. So I have simply changed CKEDITOR.htmlParser.filter to CKEDITOR["html"+"Parser"][ "fil" + "ter" ] and some other occurences.

Last edited 3 years ago by Yücel (previous) (diff)

Changed 3 years ago by Yücel

Attachment: ckeditor.js added

Working edited ckeditor.js

comment:9 Changed 3 years ago by Piotrek Koszuliński

If your VPN connection fails to load a file which contains a word "htmlParser" or "filter" it means that your VPN connection is totally broken. You need to fix it. CKEditor has nothing to do with that.

comment:10 Changed 3 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

comment:11 Changed 3 years ago by Yücel

Well, I have just given a simple temporary solution for any other one facing with this specific issue, so that they could overcome the problem by just changing a simple js file and not touching any vpn sided configs or so. But you pathetically refuse the idea. You would better try to satisfy your customer (by providing any "valid" solution) rather than slandering my solution :p

Last edited 3 years ago by Yücel (previous) (diff)

comment:12 Changed 3 years ago by Piotrek Koszuliński

I'm sorry, I thought you propose this as a patch (we really do get those). And that couldn't be accepted as a patch because there's nothing wrong with CKEditor. Just that.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy