Opened 4 years ago

Closed 4 years ago

#13706 closed Bug (invalid)

Error "Uncaught TypeError: SCAYT.prototype.IO.callback851ig80bd is not a function" when multiple textarea converted to CKEditor

Reported by: Pritesh Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Just check out fiddle here. https://jsfiddle.net/y6dfznL0/

Expected result

It shouldn't cause javascript error and Enable spell checker for all

Actual result

Spell checker doesn't work all other editors.

Other details (browser, OS, CKEditor version, installed plugins)

Working fine in IE and Edge

For Firefox,

Red underline appear for wrong spelling but right click doesn't give spelling suggestion.

For Chrome,

Doesn't work at all, you required to disable and enable it again.

Attachments (1)

_test.html (721 bytes) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (2)

Changed 4 years ago by Jakub Ś

Attachment: _test.html added

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.3

I have simplified the test case file but still the problem can be reproduced.

Since error is being thrown in SCAYT script I have reported this issue to SCAYT team: https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/106

@thecfguy - you may want to avoid creating editors with scayt turned on by default.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy