Opened 4 years ago

Closed 4 years ago

#13709 closed Bug (fixed)

[Safari] 6 red tests in delbackspacequirks/collapsed

Reported by: Piotrek Koszuliński Owned by: Piotrek Koszuliński
Priority: Normal Milestone: CKEditor 4.5.4
Component: General Version: 4.5.3
Keywords: Cc:

Description

Steps to reproduce

http://tests.ckeditor.dev:1030/#tests/is:unit,path:/tests/core/editable/keystrokes/delbackspacequirks

Expected result

Green.

Actual result

6 red tests.

Other details (browser, OS, CKEditor version, installed plugins)

Only on Safari (OSX, iOS). Upgrade Bender and related modules before reproducing.

Change History (3)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Since we're testing selection here, the only thing we can do is to expect both patterns. Note that "expected" argument of the test can be an array because isInnerHtmlMatching accepts array too.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Owner: set to Piotrek Koszuliński
Status: newassigned

comment:3 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: assignedclosed

Fixed on master with git:e994879.

I tried to figure out when these tests started failing, but downgrading to old CKE versions didn't help, as well as downgrading Bender didn't make any difference. Sad story, but it's unviable to debug it, so I just extended test so they pass in WebKit.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy