Opened 4 years ago

Closed 4 years ago

#13710 closed Bug (invalid)

Js error when removing plugins from FULL version CKEditor

Reported by: GLK Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 4.5.3
Keywords: Cc:

Description (last modified by Jakub Ś)

Steps to reproduce

  1. Standard includes to start everything off just fine.
  2. Trying to remove some plugins for a simpler look.
    $(function() {
      var ckinstance = CKEDITOR.instances['message'];
    
      delete CKEDITOR.ckinstance;
      CKEDITOR.replace( 'message',  {
          customConfig: '/js/ckeditor_email_config.js'
      });
    });   
    
  3. Followed with the email_config.js
    CKEDITOR.editorConfig = function( config ) {
    	// Define changes to default configuration here. For example:
    	  
      config.removePlugins = 'image,language,gg,flash,base64image,pastbase64'; 
      
      config.scayt_autoStartup = true;
    };
    

Expected result

FULL toolbar minus some things I don't want users to see... This list is subtantially longer in reality, but error occurs with just these!

Actual result

TypeError: a is undefined

...CKEDITOR.env.isCompatible)return null;a=CKEDITOR.dom.element.get(a);if(a.getEdit...

ckeditor.js (line 322, col 76)

Other details (browser, OS, CKEditor version, installed plugins)

Change History (4)

comment:1 Changed 4 years ago by GLK

Sorry, forgot version info:
Tested CKEditor versions 4.5.1 and 4.5.3
Firefox 40.0.3
Chrome 44.0.2403.157 m

comment:2 Changed 4 years ago by Jakub Ś

Description: modified (diff)
Keywords: Initialize config.removePlugins removed

comment:3 Changed 4 years ago by Jakub Ś

Description: modified (diff)

comment:4 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
  1. I can see that you are using many custom plugins.
  2. You must know that some plugins depend on each other. If you have an image plugin, on which other plugins depend, and you remove this plugin but not others - error will be thrown.

I have removed the language, flash and image plugin from default full package (they were created by CKSource) - but no error has been thrown. Because of that I can't see any problem in editor and will close this issue as invalid.

NOTE: Please check IE dev-tools console and see what error message is reported there. My guess is that you have some custom plugin that depends on image plugin. Your solutions are removing that custom plugin as well or bring back image plugin.


@glkaup please investigates this issue on your own. If you find the culprit and you still think this is editor fault, please comment. I will consider reopening this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy