Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13768 closed Bug (invalid)

Can't unbold text after paste text from google doc

Reported by: Duc Owned by:
Priority: Normal Milestone:
Component: General Version: 4.1.2
Keywords: Cc:

Description

Steps to reproduce

  1. Copy text from google doc that has been bolded
  2. Paste it into CK editor
  3. Select all text
  4. Try to unbold the text. You can't.

Expected result

Text should be bolded

Actual result

Text is not bolded

Other details (browser, OS, CKEditor version, installed plugins)

Any browser, Any OS, CKEditor version 4.1.2

More information, I'm using this gem https://github.com/spree-contrib/spree_editor that it's using your CK editor.

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

I have tried default editor (not spree editor) with both versions 4.1.2 and latest 4.5.3 on IE11, Chrome and FF. I didn't get any problems.

@ducnguyen please try reproducing this issue in default editor. If you will, please provide exact steps to reproduce it I will reopen this ticket and if not, please report this problem to spree editor.

comment:2 Changed 3 years ago by Duc

Hi,

I have researched and found that, I need to add the below config to solve this issue. One question: Any reason why we don't add that config as the editor's config default?

Config: CKEDITOR.editorConfig = function (config) {

config.coreStyles_bold = { element: 'b', overrides: 'strong' };

};

Thanks, Duc.

comment:3 Changed 3 years ago by Jakub Ś

Any reason why we don't add that config as the editor's config default?

Default setting in CKEditor is the other way around: http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-coreStyles_bold.

Have you made any other config settings in CKEditor that might influence Bold style? I'm asking because from what I have checked bold text is pasted with strong tags and there is no problem with activating/deactivating that style with B button.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy