Opened 3 years ago

Closed 3 years ago

#13779 closed Bug (wontfix)

Tooltips for Text Direction Buttons Show the Same Description

Reported by: Alexandru Thirtheu Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version:
Keywords: Cc:

Description

Steps to Reproduce

  1. Load an instance with the Text Direction feature: http://ckeditor.com/demo#full http://nightly.ckeditor.com/15-09-29-06-09/full/samples/ or use the CDN (https://cdn.ckeditor.com/4.5.3/full/ckeditor.js).
  2. Hover over one of the buttons to show the tooltip.
  3. Directly move over to the other button.

Expected Result

The tooltip for each button should change.

Actual Result

The initial tooltip is shown when directly subsequently hovering over either button.

Other details (browser, OS, CKEditor version, installed plugins)

This effect apparently occurs only when hovering directly between buttons, without making the tooltip disappear before reaching the other button. Subsequent changes retain the initial button's tooltip. I have not found this effect happening on other buttons so far.

  • OS:
    • Arch Linux
    • x86_64
  • Browser: Chromium
  • Version of Editor: Full
  • Plugins: None

Tried with these versions:

Attachments (1)

Chromium.png (155.8 KB) - added by Jakub Ś 3 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 in reply to:  description Changed 3 years ago by Alexandru Thirtheu

I must have mentioned that only the two buttons for setting the text direction seem to be affected, but now, I do not know how to edit the description.
And the trailing " displays right-to-left" in the last item in the list should have also been removed.

Last edited 3 years ago by Alexandru Thirtheu (previous) (diff)

comment:2 Changed 3 years ago by Jakub Ś

Keywords: Direction LTR RTL Tooltip removed
Resolution: wontfix
Status: newclosed
Version: 4.5.3

I'm sorry but this is a "Won't Fix" issue mainly because the browser is responsible for displaying tooltips. Another reason is that text in title attribute is different for both buttons yet Chromium doesn't change them (Please see attached image).

Another important thing is that this problem occurs only in Chromium. I have checked FF, Chrome, Opera on Windows, Linux and didn't observer any such behaviour.

This ticket should rather be reported to Chromium team.

Changed 3 years ago by Jakub Ś

Attachment: Chromium.png added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy