Opened 4 years ago

Closed 3 years ago

#13781 closed Bug (expired)

CKEditor didn't work properly while typing Chinese characters

Reported by: qingfanpeng Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

When trying to enter Chinese character using pinyin, the word options list disappeared after typed in the first letter (it didn't wait until I finish typing the whole pinyin) and it just auto select the first letter at once. I guess it's similar with this one https://dev.ckeditor.com/ticket/11663

I tested on here http://ckeditor.com/demo in standard model. The issue appeared, it's similar but not exactly same thing.

Steps to reproduce

  1. Type some Chinese characters

2.Click a font format button e.g 'Bold'

  1. Continue typing, the issue will appears

Expected result

Select Chinese characters when I finish typing the whole pinyin (usually triggers by space )

Actual result

Just select pinyin letter at once.

Other details (browser, OS, CKEditor version, installed plugins)

Browser: Google Chrome 45.0.2454.99 OS: OSX Yosemite 10.10.5 CKEditor version: 4.5.1 Installed plugins: divarea, autogrow ,placeholder,confighelper

Attachments (2)

query_params2.gif (148.6 KB) - added by qingfanpeng 4 years ago.
query_params3.gif (184.6 KB) - added by qingfanpeng 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by qingfanpeng

Attachment: query_params2.gif added

Changed 4 years ago by qingfanpeng

Attachment: query_params3.gif added

comment:1 Changed 4 years ago by qingfanpeng

Version: 4.5.14.5.3

comment:2 Changed 4 years ago by Jakub Ś

Keywords: pinyin removed
Status: newpending
Version: 4.5.3

I have tried:

  • CKEditor 4.5.7 and 4.5.1 with mentioned plugins (without confighelper as this is not CKSource plugin)
  • Latest Chrome 49 on Mac 10.11 and Windows 7
  • Chinese Traditional and Simplified
  • I have been typing s'js'f, then pressing bold and typing the same set of characters. Both have given same result.

I could not reproduce this problem. Everything seems to work fine.

Are you still able to reproduce this issue in our demo page? What are the exact steps to reproduce this issue?
Please try reproducing in standalone CKEditor or in our demo page to exclude possibility that some third-party script from your app is influencing this behaviour.

comment:3 Changed 3 years ago by Jakub Ś

Resolution: expired
Status: pendingclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy