Opened 4 years ago

Closed 4 years ago

#13783 closed Bug (duplicate)

Class not removed if format was changed

Reported by: Andreas Gyr Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: format Cc:

Description

Steps to reproduce

  1. Visit http://sdk.ckeditor.com/samples/format.html and scroll down to "Custom Text Format Definition"
  2. Inside the Editor inspect the code below the "The Algorithm" heading. It is an <pre> Element with class "formattedCode"
  3. Click on the Code and Switch Fomat from to normal
  4. Inspect the Code again. The Element is now <p> but the class is still there
  5. Click Sourcecode twice
  6. Now the class is gone

Expected result

The class should be removed if format was changed.

Actual result

The class is still there.

Other details (browser, OS, CKEditor version, installed plugins)

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.3

DUP of #12526.

Another thing that I should explain is that class is removed because of Advanced Content Filter (ACF) being turned on. The main issue however is that format dropdown doesn't remove styles for block-level elements (or that styles system should be rewritten).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy