Opened 3 years ago

Last modified 2 years ago

#13798 review Bug

Changing paragraph format causes cursor to move on Firefox 41

Reported by: Vangelis Owned by: Tomasz Jakut
Priority: Nice to have (we want to work on it) Milestone:
Component: Core : Focus Version:
Keywords: Firefox Cc:

Description

Steps to reproduce

  1. On the CKEditor Demo page, set the cursor anywhere in the middle of a heading.
  2. Press Enter.
  3. Change the paragraph format to Normal.
  4. Press Backspace.

Actual result

Cursor has moved to the end of the line.

Change History (19)

comment:1 Changed 3 years ago by Piotrek Koszuliński

Keywords: Firefox added; firefox removed
Milestone: CKEditor 4.5.5
Status: newconfirmed

I can confirm it. It can be reproduced in FF 41 (but also FF 37) and in CKE 4.5.4 (but also 4.5.0). So it does not seem to be a recent regression in either CKEditor or FF.

comment:2 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:3 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

It seems that old fix for Webkit is also working in Gecko, so I've just switched it on in Firefox - pushed branch:t/13798

comment:4 Changed 3 years ago by Marek Lewandowski

Status: reviewreview_failed

This custom handling in fact deals with this issue. We'll have to put some extra attention to delete/backspacing in testing phase for FF.

The only problem is that tests can definitely be moved to editable component. tests/core/editable/keystrokes/keystrokes.js is a good match for js tests. As for MT it can remain in ticket directory, it's fine. Pushed minor changes to t/13798 branch.

comment:5 Changed 3 years ago by Tomasz Jakut

Status: review_failedreview

Moved tests to tests/core/editable/keystrokes/keystrokes.js & pushed branch:t/13798.

comment:6 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: reviewclosed

Merged to master with git:8565201.

comment:7 Changed 3 years ago by Olek Nowodziński

Resolution: fixed
Status: closedreopened

This ticket enables custom DEL/BACKSPACE handling in FF but does not activate proper tests (1, 2) which turn out to be mostly red.

comment:8 Changed 3 years ago by Marek Lewandowski

As @a.nowodzinski points out we're not running all tests for commited part of code. Initially it was created for Chrome, and it got solid portion of tests.

See: https://github.com/ckeditor/ckeditor-dev/blob/870c1a2a7af6611e00d379bb470742021dac59f2/tests/core/editable/keystrokes/delbackspacequirks/expanded.js#L20 https://github.com/ckeditor/ckeditor-dev/blob/870c1a2a7af6611e00d379bb470742021dac59f2/tests/core/editable/keystrokes/delbackspacequirks/collapsed.js#L30

Currently many of them are failing, it might be due to bogus BR, but we have to little time to verify it, so this merge will be reverted and resolved in next milestone.

comment:9 Changed 3 years ago by Olek Nowodziński

Milestone: CKEditor 4.5.5CKEditor 4.5.6

I reverted git:fc399b7 from master. Re-attaching to the next milestone.

comment:10 Changed 3 years ago by Jakub Ś

Status: reopenedconfirmed

comment:11 Changed 3 years ago by Tomasz Jakut

Status: confirmedreview

The tests were failing due to bogus br. I've updated them & pushed branch:t/13798.

comment:12 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:13 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7CKEditor 4.5.8

comment:14 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8CKEditor 4.5.9

comment:15 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9CKEditor 4.5.10

comment:16 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.10CKEditor 4.5.11

Moving tickets to the next milestone.

comment:17 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.11CKEditor 4.6.1

comment:18 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.6.2

Moving to 4.6.2 minor release, as 4.6.1 is mostly about polishing 4.6.0.

comment:19 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.2
Priority: NormalNice to have (we want to work on it)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy