Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#13821 closed Bug (duplicate)

Background color may be lost when changing Font Size

Reported by: Wayne Christian Owned by: Tomasz Jakut
Priority: Normal Milestone:
Component: Core : Styles Version: 4.4.6
Keywords: fontsize Cc:

Description

Reproduced on full editor

Steps to reproduce

Via Content panel, create 'Text' visual Click inside the Text visual to surface the Editor

Via Editor, change Text Color to 'Blue' enter some text looks good; see blue text

Via Editor, change Font Size to 16

Continue entering text... See blue text in new (16) font size as expected

Via Editor, change Background Color to 'Yellow'

Continue entering text... See blue text with yellow backgroud in 16 font size as expected

so far, so good

Now, change Font Size to 20

Continue entering text...

Expected result

background yellow color should be retained when font size is changed

Actual result

  • Unexpectedly, we only see blue text. The background color (yellow in this case) has been lost

Other details (browser, OS, CKEditor version, installed plugins)

OS=Windows, Browse=Chrome, IE11, Firefox 38.0.5

Change History (15)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: formatting removed
Status: newconfirmed
Version: 4.4.74.4.6

Problem can be reproduced from CKEditor 4.4.6.

HTML produced is:

<p><span style="color:#0000FF">test1<span style="font-size:20px">test2<span style="background-color:#FFFF00">test3</span></span><span style="font-size:26px">test4</span></span></p>

instead of

<p><span style="color:#0000FF">test1<span style="font-size:20px">test2<span style="background-color:#FFFF00">test3<span style="font-size:26px">test4</span></span></span></span></p>

In case this is unclear:

  1. Set font color to blue and type
  2. Set font size to 16 and type
  3. Set font background-color to yellow and type
  4. Set font size to 20 and type

comment:2 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6

comment:3 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:4 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

Probably is better to clone span with background to the new element - otherwise there are problems with line height. Pushed branch:t/13821.

comment:5 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:6 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7CKEditor 4.5.8

comment:7 Changed 3 years ago by Marek Lewandowski

Issue #14368 might be related to this one.

comment:8 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8CKEditor 4.5.9

comment:9 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9CKEditor 4.5.10

comment:10 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.10CKEditor 4.5.11

Moving tickets to the next milestone.

comment:11 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.11CKEditor 4.6.1

comment:12 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.1CKEditor 4.6.2

Moving to 4.6.2 minor release, as 4.6.1 is mostly about polishing 4.6.0.

comment:13 Changed 2 years ago by kkrzton

This issue might be related to #14856.

comment:14 Changed 2 years ago by kkrzton

Resolution: duplicate
Status: reviewclosed

This is a duplicate of #14856. As #14856 is already R+ and introduces more general fix, I am closing this one.

comment:15 Changed 2 years ago by Marek Lewandowski

Milestone: CKEditor 4.6.2

Dropping from milestone since it's a duplicate.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy