Opened 3 years ago

Closed 3 years ago

#14368 closed Bug (duplicate)

change text background twice, cause the color to be lost

Reported by: Anas Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Cc:

Description (last modified by Marek Lewandowski)

Steps to reproduce

Simplified the test case:

  1. Open the editor and set the following source:
<p><span style="color:#00FF00">Sample line</span></p>
  1. Put the selection in the middle of line: Sample ^line.
  2. Apply red font color using the "Text Color" button.

Expected:

Red font color should be applied only to what you're about to write.

Actual:

Text color of the paragraph is removed.

Additional notes:

  1. Interesting note is that span[style="color:#FF0000;"] has been created for the red font color, but the selection is not placed within that span (that's the case at least for Chrome, because IE11 is able to put the selection correctly).
  2. This issue might be similar to #13821.
  3. Could be reproduced with Chrome, Firefox and IE11.

Other details (browser, OS, CKEditor version, installed plugins)

Chrome Version 48.0.2564.97 m Win 8.1 CKEditor version 4.5.5 (also active on the live website and the nightly build). You can use the default config on the website demo, also i Attached is my build-config.js.

Attachments (1)

build-config.js (2.1 KB) - added by Anas 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by Anas

Attachment: build-config.js added

comment:1 Changed 3 years ago by Marek Lewandowski

Description: modified (diff)

Simplified test case.

comment:2 Changed 3 years ago by Marek Lewandowski

Status: newconfirmed

I can reproduce issue at least since 4.0.0.

comment:3 Changed 3 years ago by Marek Lewandowski

Keywords: change text background twice removed
Version: 4.5.54.0

comment:4 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This issue is in fact a duplicate of #8934 which is very similar to #10650 (These two are however not duplicates - they may have same source of the problem but TC and browsers differ).

Another ticket worth mentioning is #10995

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy