Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13849 closed Bug (invalid)

Firefox: Opens a blank Browse Server window

Reported by: basile Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. In the CKEditor click anywhere in the text
  2. Click on the "Image" button and the "Image Properties" dialog pops up.
  3. Click on the "Browse Server" button next to the "URL" field pops up an empty browser window.

Expected result

Open the browse server window

Actual result

Opens a blank browser windows

Other details (browser, OS, CKEditor version, installed plugins)

Tested on http://ckeditor.com/demo. Couldn't test it http://nightly.ckeditor.com/ because the "Browser Server" button is not enabled.

Tested Firefox Developer Edition v43.0a2 (2015-10-19), Windows 7 Enterprise SP1 64-bit and it doesn't work.

Tested on Google Chrome v46.0.2490.71m and it works.

Tested on Internet Explorer v11.0.9600.17843 and it works.

Change History (7)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.4

Tested Firefox Developer Edition v43.0a2

Stable version for Firefox is 41.0.2 and Browser Server button works there. Let's wait for Firefox to actually release version 43.

comment:2 in reply to:  1 Changed 3 years ago by basile

Replying to j.swiderski:

Tested Firefox Developer Edition v43.0a2

Stable version for Firefox is 41.0.2 and Browser Server button works there. Let's wait for Firefox to actually release version 43.


v41 is the latest stable version for users.
v43 is the latest stable version for developers (that's why it's no longer called Aurora as it used to be).

You can read more here: https://hacks.mozilla.org/2014/11/mozilla-introduces-the-first-browser-built-for-developers-firefox-developer-edition/

Edit: You can even find it officially linked on the main page of https://www.mozilla.org/

Last edited 3 years ago by basile (previous) (diff)

comment:3 Changed 3 years ago by Jakub Ś

Excuse me for being sarcastic but please answer this: is web site or application, once it is done, being served to users on FF v41 (for users) or on FF v43 (for developers)?

  1. It is possible that one of add-ons is causing conflict with popup window.
  2. It is possible that FF v43 is not exact fork of the stable release

If Popup works in browser for users but doesn't in the one for developers then I think this issue should be rather reported to FF team.

comment:4 in reply to:  3 Changed 3 years ago by basile

Replying to j.swiderski:

Excuse me for being sarcastic but please answer this: is web site or application, once it is done, being served to users on FF v41 (for users) or on FF v43 (for developers)?

It's not about a specific site, but for all the sites that use CKEditor with a File Browser. Some built by me, many many more others build by others.
It just happened that I noticed it when building a community site with some friends.

  1. It is possible that one of add-ons is causing conflict with popup window.

I tried disabling all the add-ons and the popup window was still a blank page.

  1. It is possible that FF v43 is not exact fork of the stable release

If Popup works in browser for users but doesn't in the one for developers then I think this issue should be rather reported to FF team.

I will definitely post a bug report to the FF team too.
Once I do I will link it here too.

Edit: I did post to the bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1216479

Last edited 3 years ago by basile (previous) (diff)

comment:5 Changed 3 years ago by Jakub Ś

I understand completely what you are trying to say but the problem that I see is that FF v41 and FF v43 are both latest stable and yet CKFinder popup works perfectly in one but not the other.
I was thinking that perhaps some add-on is simply conflicting with popup. That would be something to consider fixing on CKEditor side but you have told me that you have disabled all the add-ons and it still didn't work.
Taking the above into account we have two same and latest stable browsers but only one of them works with CKEditor popup.


@basile I will give a try to FF v43 and see if after disabling all the add-ons popup, it will work or not. I mean no offense here but perhaps there is a slight chance you have missed something.

comment:6 in reply to:  5 Changed 3 years ago by basile

Yesterday v44.0a2 (2015-11-03) was release and the CKFinder popup is working again as it should.

Haven't tested it on v42 though.

comment:7 Changed 3 years ago by Jakub Ś

Thank you for letting me know. I didn't have in fact time to test this when I have written my last comment 2 weeks ago.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy