Opened 3 years ago

Closed 3 years ago

#13854 closed Bug (duplicate)

Data loss on copy and pasted content from MS-Word 2010 into CKEditor

Reported by: Pravin Owned by:
Priority: Normal Milestone:
Component: Core : Pasting Version:
Keywords: Cc:

Description

Steps to reproduce

Our client prepare contents in various version of MS-Office. When using MS-Word 2010 with bullets points and if the first word of that bullet point is hyperlink then hyperlink gets deleted in IE11.

Original text is as follows

► xyz.com brings Lorem ipsum dolor sit amet, xyz.com consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec quam felis, ultricies nec, pellentesque eu, pretium quis, sem. Nulla consequat massa quis enim. Donec pede justo, fringilla vel, aliquet nec, vulputate eget, arcu. In enim justo, rhoncus ut, imperdiet a, venenatis vitae, justo. Nullam dictum felis eu pede mollis pretium. Integer tincidunt. Cras dapibus. Vivamus elementum semper nisi. Aenean vulputate eleifend tellus. Aenean leo ligula, porttitor eu, consequat vitae, eleifend ac, enim. Aliquam lorem ante, dapibus in, viverra quis, feugiat a, tellus. Phasellus viverra nulla ut metus varius laoreet. Quisque rutrum. Aenean imperdiet. Etiam ultricies nisi vel augue. Curabitur ullamcorper ultricies nisi xyx.com gets deleted and the above text become as follows

Missing data

xyx.com gets deleted and replaced with '< >'. The above text become as follows

Actual result

< > brings Lorem ipsum dolor sit amet, xyz.com consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec quam felis, ultricies nec, pellentesque eu, pretium quis, sem. Nulla consequat massa quis enim. Donec pede justo, fringilla vel, aliquet nec, vulputate eget, arcu. In enim justo, rhoncus ut, imperdiet a, venenatis vitae, justo. Nullam dictum felis eu pede mollis pretium. Integer tincidunt. Cras dapibus. Vivamus elementum semper nisi. Aenean vulputate eleifend tellus. Aenean leo ligula, porttitor eu, consequat vitae, eleifend ac, enim. Aliquam lorem ante, dapibus in, viverra quis, feugiat a, tellus. Phasellus viverra nulla ut metus varius laoreet. Quisque rutrum. Aenean imperdiet. Etiam ultricies nisi vel augue. Curabitur

Other details (browser, OS, CKEditor version, installed plugins)

CKEditor 4 It happens only in IE11 if copy pasted from MS-2010 and bulleted text starting with hyperlink

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.4

This issue has been fixed in CKEditor 4.5.2 and from what I have chcekced Word doc with list starting with link also work there. Please see #11376.

I'm closing this ticket as duplicate but if you can reproduce this issue in 4.5.4, please provide Word file which is causing problems for you.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy