Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13873 closed Bug (wontfix)

CKEditor 3.6.6 Paste buttons behaviour broken in latest Firefox version 41

Reported by: zoey Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version: 3.6.6
Keywords: Cc:

Description

Steps to reproduce

  1. Using CKEditor 3.6.6

We have integrated the editor version 3.6.6 into our content management system [CMS] which also has some website-specific editor add-ons configured and therefore upgrading is not an option for our website.

  1. Use latest Firefox version 41+
  2. For reference purposes, the editor toolbar on previous Firefox versions worked correctly.

Expected result

Previously, upon entering the editor text box to post an article - text, photos, etc. - the clipboard buttons were used to update content (copy/paste) using Word documents *.doc, Open Documents *.odt, or plain text.

Actual result

The clipboard worked well until the latest updates to Firefox. The clipboard buttons become unhighlighted when we enter into the text box to begin to post information.

This behaviour only affects the latest Firefox. Internet Explorer and Google Chrome work correctly, but our volunteers do not use those browsers, preferring the open source community software instead.

Other details (browser, OS, CKEditor version, installed plugins)

We have been promoting open source software for both server and desktops since the early 1990's, with LAMP servers and netscape/firefox browsers. All our volunteers use Firefox to update the website and wish to happily continue the tradition as we did.

We need a resolution to this clipboard toolbar, a code snippet to the module(s) affected, to ensure our current interface will function properly for years to come.

Thank you to the open source community.

Attachments (2)

ckeditor-3-6-6-clipboard-default-state.jpg (62.6 KB) - added by zoey 3 years ago.
CKEditor 3.6.6 toolbar within our content management system interface showing the clipboard buttons functioning and appearing properly.
ckeditor-3-6-6-clipboard-buttons-unhighlighted-upon-entering-into-textbox.jpg (65.1 KB) - added by zoey 3 years ago.
CKEditor 3.6.6 toolbar within our content management system interface showing the clipboard buttons becoming unhighlighted when entering into the textbox. The temporary workaround is to click on the Source button twice (enter into and out of source code) and the clipboard buttons become highlighted again.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by zoey

CKEditor 3.6.6 toolbar within our content management system interface showing the clipboard buttons functioning and appearing properly.

Changed 3 years ago by zoey

CKEditor 3.6.6 toolbar within our content management system interface showing the clipboard buttons becoming unhighlighted when entering into the textbox. The temporary workaround is to click on the Source button twice (enter into and out of source code) and the clipboard buttons become highlighted again.

comment:1 Changed 3 years ago by James McQuaid

The temporary workaround described (click on the Source button twice and the clipboard buttons become highlighted again), does not function. The clipboard buttons subsequently deactivate when one clicks into the editing window.

comment:2 Changed 3 years ago by Jakub Ś

Keywords: paste word clipboard toolbar button unhighlighted removed
Resolution: wontfix
Status: newclosed

some website-specific editor add-ons configured and therefore upgrading is not an option for our website.

I'm sorry but CKEditor 3.6.x is no longer actively developed thus the only option for you is upgrading to CKEditor 4.x (I recommend the latest 4.5.4).

comment:3 Changed 3 years ago by James McQuaid

We are experiencing this issue in the latest Drupal version 7.x-1.16 (https://www.drupal.org/project/ckeditor)

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy