Opened 4 years ago

Closed 3 years ago

#13924 closed Bug (wontfix)

IE11 - Typing is slow after pasting for the second time into editor.

Reported by: Jakub Ś Owned by: Tomasz Jakut
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: IE11 support Cc:

Description

Steps to reproduce

  1. Open attached 27 page document and paste it into editor.
  2. Start typing immediately after paste. Document is being still processed so first characters my not show up but later on you can type without problems
  3. Press Ctrl+A and Backspace (you can press delete and backspace few times - it doesn't matter)
  4. Paste text again and again after the text shows up start typing.

Actually you can wait few seconds and then start typing.

Expected result

Typing speed should be normal.

Actual result

Typing is very slow even after few minutes.

Other details (browser, OS, CKEditor version, installed plugins)

Problem can be reproduced in IE11 only. IE11 is supported from CKEditor 4.3 but I have seen this issue even in CKEditor 4.0.

Attachments (2)

test.docx (45.5 KB) - added by Jakub Ś 4 years ago.
2015-11-12_1054.swf (892.1 KB) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (18)

Changed 4 years ago by Jakub Ś

Attachment: test.docx added

Changed 4 years ago by Jakub Ś

Attachment: 2015-11-12_1054.swf added

comment:1 Changed 4 years ago by Jakub Ś

Keywords: support added
Status: newconfirmed

comment:2 Changed 4 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6

comment:3 Changed 4 years ago by Tade0

Owner: set to Tade0
Status: confirmedassigned

comment:4 Changed 4 years ago by Tade0

I did a few test, here are the results:

-Going through the steps on a VirtualBox VM with 128MB video memory reproduces the problem even at step 2.

-Changing the video memory to 256MB (max available) makes the problem appear at step 4.

-After step 4. the profiler shows, that the vast majority of processing power is dedicated to handling the native innerHtml method.

comment:5 Changed 4 years ago by Marek Lewandowski

Rather than video memory it should depend on system RAM memory. Set it simply to something like 2gb and then see the results.

Also compare how does it work for IE10, IE9, Edge - is IE11 the only one browser having this problem?

comment:6 Changed 4 years ago by Tade0

Tested it on IE8, IE11 and Edge. Among them only IE11 seems to have this "feature".

comment:7 Changed 4 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:8 Changed 3 years ago by Jakub Ś

One of our users/customers have provided temporary workaround.

Recently we found out that typing becomes faster if you activate and deactivate the “Source Code” mode after pasting the large document into the CKEditor instance.

/**
* Workaround for pasting problems with IE11
*/
CKEDITOR.plugins.add('iepaste-workaround', {
       init : function(editor) {
             if(CKEDITOR.env.ie) {
                    editor.on('paste', function(evt) {// Show screen lock
                    });
                    editor.on('afterPaste', function(evt) {
                           var editor = evt.editor;
                           var bookmarks = editor.getSelection().createBookmarks2();
                           editor.setData(editor.getData(), {
                                  callback: function() {
                                         try {
                                               var selection = editor.getSelection();
                                               selection.selectBookmarks(bookmarks);
                                               selection.scrollIntoView();

                                        } finally {
                    // Close screen lock
                                        }
                                  }
                           });
                    });
             }
      }
});

comment:9 Changed 3 years ago by Tomasz Jakut

Owner: changed from Tade0 to Tomasz Jakut

comment:10 Changed 3 years ago by Tomasz Jakut

It seems that problem is caused by selecting range after inserting pasted data into it. Everything works fine without touching the range.

Moreover it could be bug in IE with handling native selections as simplifying our handler for selecting ranges does not solve the problem.

comment:11 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7CKEditor 4.5.8

This issue is really complex, we're unable to squeeze it into 4.5.7.

comment:12 Changed 3 years ago by Tomasz Jakut

The problem could be easily reproduced outside the CKEditor, as shown in that demo.

Bug was reported to MS.

comment:13 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8CKEditor 4.5.9

comment:14 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9CKEditor 4.5.10

comment:15 Changed 3 years ago by Tomasz Jakut

Issue in IE's bug tracker is marked as won't fix. Therefore, unfortunately, we are not able to do any more without Microsoft support.

Last edited 3 years ago by Tomasz Jakut (previous) (diff)

comment:16 Changed 3 years ago by Tomasz Jakut

Milestone: CKEditor 4.5.10
Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy