Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13941 closed Bug (invalid)

FF: Autogrow not working when you paste following table in HTML source & switch to rich text

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.4
Keywords: Cc: Irina, chrisgui

Description

Steps to reproduce

  1. Open CK Editor sample with Autogrow enabled.
  2. Copy HTML Souce from atttached doc & paste in HTML Souce
  3. Switch to Rich text

Issue:

Autogrow not kicked in & there is no way for mouse user to navigate to content in table cells or content below it

Attachments (3)

sample Table html.txt (18.1 KB) - added by Satya Minnekanti 4 years ago.
2015-11-16_1255.swf (2.5 MB) - added by Jakub Ś 4 years ago.
autogrow works.png (104.3 KB) - added by Jakub Ś 4 years ago.

Change History (8)

Changed 4 years ago by Satya Minnekanti

Attachment: sample Table html.txt added

Changed 4 years ago by Jakub Ś

Attachment: 2015-11-16_1255.swf added

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

@satya, please see attached file. I have tried pasting the table into autogrow sample and it worked as expected. Firefox version tested was 42.

I'm closing this issue as invalid for now but will reopen it once you provide more details.

comment:2 in reply to:  1 Changed 4 years ago by Satya Minnekanti

Replying to j.swiderski:

@satya, please see attached file. I have tried pasting the table into autogrow sample and it worked as expected. Firefox version tested was 42.

I'm closing this issue as invalid for now but will reopen it once you provide more details.

@j.swiderki pls try it http://sdk.ckeditor.com/samples/autogrow.html I'm using FF 42 and i could still reproduce the issue. Please re-open it

Changed 4 years ago by Jakub Ś

Attachment: autogrow works.png added

comment:3 Changed 4 years ago by Jakub Ś

@satya, please see latest attached file. The autogrow kicks-in when switching to wysiwyg. I have checked this in Firefox 42. I'm sorry but I can't reopen the ticket as autogrow works as expected.

NOTE: @satya, perhaps you have some custom add-on which breaks the autogrow? Could you disable all of them, clear (not refresh with Ctrl+F5) browser's cache and recheck?

comment:4 Changed 4 years ago by Edson

Change

<table align="left" border="0"...

to

<table border="0"

https://jsfiddle.net/sttevgws/8/

Last edited 4 years ago by Edson (previous) (diff)

comment:5 Changed 4 years ago by Jakub Ś

@edsonperotoni thak you for clarification. From what I have checked align=left has nothing to do with this issue. It seems that autogrow is not fired only on initial load (mode change works as expected) but this is not a bug. Please see http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-autoGrow_onStartup.

With that option enabled, everything works as expected. Issue is still invalid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy