Opened 12 years ago

Closed 7 years ago

#1404 closed New Feature (invalid)

Replace the this pointer with a local var for denser packing

Reported by: Joe Wieloch Owned by:
Priority: Normal Milestone:
Component: Project : CKPackager Version:
Keywords: Cc:

Description

It would be nice if ... the packager replaced the this pointer with a one character local variable in functions, saving three characters per "this" use.

The only problem I can think of is if a function is nested inside another function. In that case a separate local variable definition should be used inside that function for the this pointer (it might be being assigned to a different object).

The definition takes up space so it only makes sense for functions that have five or more this pointers.

Change History (2)

comment:1 Changed 11 years ago by Artur Formella

Keywords: Confirmed added

comment:2 Changed 7 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

Since 4.0 CKBuilder uses Google Closure Compiler so:

  • we can't easily modify its behaviour,
  • it uses very complex algorithms for optimization, so we don't have to add ours,
  • such a micro optimizations very often doesn't work well with gzip.
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy