Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14253 closed Bug (invalid)

Splits <a> and <span> tags

Reported by: Viresh Shah Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: vireshshah@…

Description

I'm using Drupal CKEditor module which uses CKEditor v4.4.3. Consider below markup I'm using in ckeditor. You can see in action: http://screencast.com/t/hsbU2jUN

<p><span>My Span</span><a href="/hello-world">Hello World</a></p>

Once you toogle the editor view, it splits <a> tag to like <a href="/hello-world">Hello</a><a href="/hello-world"> World</a> and <span> to <span>My </span><span>Span</span>. So final markup becomes:

<p><span>My </span><span>Span</span><a href="/hello-world">Hello</a><a href="/hello-world"> World</a></p>.

However, if you put space between closing span and beginning a tag, then it works fine. I also tired disabling advance content filter in CKEditor settings but it didn't help.

Any help would be highly appreciated.

Attachments (1)

ckeditor-splits-tags-bug.swf (1.2 MB) - added by Viresh Shah 4 years ago.
Steps to reproduce this error.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by Viresh Shah

Steps to reproduce this error.

comment:1 Changed 4 years ago by Viresh Shah

Cc: vireshshah@… added

comment:2 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.3

I have tried reproducing this issue in latest stable editor but no luck. I have also tried latest nightly: http://nightly.ckeditor.com/15-12-14-07-08/standard/samples/. Also no luck.

  1. Please make sure that issue isn't caused by third-party plugins like word count. These plugins were created by community and not by CKSource. Because we are not the author, we can't support these plugins. If custom plugin is a problem, such bug should be reported to plugin author. Don't forget to clear Drupal cache after making changes.
  2. Please make sure that some Drupal filter is not causing this issue. Don't forget to clear Drupal cache after disabling filters.
  3. You can also try upgrading client-side to latest 4.5.6 version or at least to 4.4.8.

I will close this issue as I haven't been able to reproduce this problem in standalone CKEditor. If you are able to reproduce this issue in plain CKEditor, please leave a comment and i will reopen the ticket. If no filter or third-party plugin is causing this, you can report this issue on CKE for Drupal page: https://www.drupal.org/project/ckeditor

comment:3 Changed 4 years ago by Viresh Shah

Thanks for your help. So here what I tried:

  1. We're not using "word count" plugin.
  2. I disabled all filters but no luck.
  3. I upgraded client side to latest 4.5.6 but no luck.

So finally I found issue is with "scayt" plugin. If I disable it using "config.scayt_autoStartup = false;" then it works fine. I'm not sure whether you own this plugin but I would appreciate if we can get patch for this.

Thanks!

comment:4 Changed 4 years ago by Jakub Ś

I'm sorry but With or without SCAYT plugin enabled I was not able to reproduce this problem. We have tried two different machines but everything was working as expected.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy