Opened 4 years ago

Closed 4 years ago

#14269 closed Bug (invalid)

Number Bullets pasting problem while pasting text from Word file to CK Editor.

Reported by: Priyanka Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.4
Keywords: Cc:

Description

"This ticket is similar to #14246"

Steps to reproduce

1.Copy the following content from the Microsoft Word file(Also see the attachment: Text_pasted_from_word.docx.).

A)Names

I)ABCD

II)PQRS

B)Numbers

I)5541515

II)5413213

C)Address

I)ABC Streets

II)PQR Streets

2.Paste the content into the CK Editor using ctrl+v or "Paste from Word" option on the CK Editor panel.

Expected result

The text must be printed as:

A)Names

I)ABCD

II)PQRS

B)Numbers

I)5541515

II)5413213

C)Address

I)ABC Streets

II)PQR Streets

Actual result

But in the Full featured CK Editor it is printed as( Please see attachment: CKEditor_pasted.PNG) :

A.Names

I.ABCD

II.PQRS

A.Numbers

I.5541515

II.5413213

A.Address

I.ABC Streets

II.PQR Streets

Everytime the entry appears as A. Also,in CK Editor, the tab space for sub-entries is also not pasted correctly.

Other details

Browser:Internet Explorer

Operating System : Windows 7 Enterprise

CK Editor version:4.5.6

Attachments (2)

CKEditor_paste.PNG (44.8 KB) - added by Priyanka 4 years ago.
Text_pasted_from_word.docx (14.8 KB) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Priyanka

Attachment: CKEditor_paste.PNG added

Changed 4 years ago by Jakub Ś

Attachment: Text_pasted_from_word.docx added

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
  1. Please have a look at the code that browser sees for your list:
    <p class="MsoListParagraphCxSpFirst" style="text-indent:-18.0pt;mso-list:l3 level1 lfo1"><!--[if !supportLists]--><span lang="EN-US">A)<span style="font-stretch: normal; font-size: 7pt;">&nbsp;&nbsp;&nbsp;&nbsp;
    </span></span><!--[endif]--><span dir="LTR"></span><span lang="EN-US">Names<o:p></o:p></span></p><p class="MsoListParagraphCxSpMiddle" style="margin-left:72.0pt;mso-add-space:
    auto;text-indent:-18.0pt;mso-list:l1 level1 lfo3"><!--[if !supportLists]--><span lang="EN-US">I)<span style="font-stretch: normal; font-size: 7pt;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
    </span></span><!--[endif]--><span dir="LTR"></span><span lang="EN-US">ABCD<o:p></o:p></span></p>
    
  1. Now please have a look at attached file (I have added my list there) and how browser sees my list:
    <p class="MsoNormal"><span lang="EN-US">&nbsp;</span></p><p class="MsoListParagraphCxSpFirst" style="text-indent:-18.0pt;mso-list:l0 level1 lfo1"><!--[if !supportLists]--><span lang="EN-US">1.<span style="font-stretch: normal; font-size: 7pt;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
    </span></span><!--[endif]--><span dir="LTR"></span><span lang="EN-US">Test1<o:p></o:p></span></p><p class="MsoListParagraphCxSpMiddle" style="margin-left:72.0pt;mso-add-space:
    auto;text-indent:-18.0pt;mso-list:l0 level2 lfo1"><!--[if !supportLists]--><span lang="EN-US">a.<span style="font-stretch: normal; font-size: 7pt;">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
    
    </span></span><!--[endif]--><span dir="LTR"></span><span lang="EN-US">TestA<o:p></o:p></span></p>
    

Problem are levels - in your case all items have level1 while in mine they have level1 and level2

Since browser sees your list the way it sees, there is nothing we can do.

Try using different method of creating nested lists in MS WORD. Normally you create elemenets on one level and next tab these elements which should go to next level.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy