Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14308 closed Bug (invalid)

Issue with CKFinder "Unparseable Date" using ColdFusion and CKFinder 2

Reported by: Kaustav Owned by:
Priority: Normal Milestone:
Component: Server : ColdFusion Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Windows Server
  2. older Jquery instance (1.9 with Jquery Migrate tool installed)
  3. Run CKFinder in environment

Expected result

Normal Directory Listing

Actual result

"unparsable date" error upon trying to load file browser

Other details (browser, OS, CKEditor version, installed plugins)

Attachments (1)

procopioissue.jpg (70.2 KB) - added by Kaustav 3 years ago.
Screenshot of the error

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Kaustav

Attachment: procopioissue.jpg added

Screenshot of the error

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.4

Since this issue concerns CKFinder and not CKEditor, I will need to close it here. I will report it to CKFinder private bug tracker once I'm able to reproduce it. Let's continue this topic here anyway.

Now, I haven't been able to reproduce this is in default CKFinder. I have just put latest CKFinder into CF server and run it. Next I have tried all the available operations and none has shown this error.

Are you able to reproduce this issue in default CKFinder or only when it is integrated into your application? Are you able to provide reduced sample file that I can put into CKFinder samples folder and see this issue?

Which CF version you use? Perhaps there is some special setup in your server or regional setup which breaks date parsing?

comment:2 Changed 3 years ago by Kaustav

We’ve been able to narrow down the issue to only occurring for folders where files have no “modified date”. The files were added using an older version of Ckfinder. New files added via current CKfinder to a new directory have a modified date that is the same as their created date, the error does not appear here. It definitely seems to only be caused by files that have no modified date.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy