Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14416 closed Bug (invalid)

WCAG 2.0 violation reported on the page that contains CK Editor

Reported by: IBM_RQM Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.3
Keywords: IBM, RQM Cc:

Description

Following violation is reported on a page that contains CK Editor - The page must provide a link to skip directly to the main page content as the first link on each page or use WAI-ARIA landmarks.

We have scanned the page using IBM Rational Policy Tester. You can find more details about the error on the following link - http://ausgsa.ibm.com/projects/h/haactools/w3/magicbutton/plugincfg/rulepack/help/idhi_accessibility_check_g1046.html

Attachments (1)

CKEditor_Violation.png (413.0 KB) - added by IBM_RQM 4 years ago.
Violation reported on a page containing CK Editor

Download all attachments as: .zip

Change History (10)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

Please go to e.g. http://ec.europa.eu/index_en.htm and press tab. Page focuses "Skip to main content" link.

While this makes sense for CKEditor pages, I don't see how it makes sense for CKEditor itself. Since this bug tracker concerns only the editor I will need to close this issue as invalid and have it reported in our internal bug tracker

comment:2 Changed 4 years ago by IBM_RQM

Hi, Can I have the internal bug tracker ticket number ? We will need it for tracking purpose.

The issue is reported as violation because CKEditor creates an iFrame containing the html page. This issue can be fixed by setting role as textarea to the region.

comment:3 Changed 4 years ago by Jakub Ś

The ticket number in our internal tracker for web sites is 1634.

comment:4 Changed 4 years ago by IBM_RQM

Hi, how can I check the status of internal ticket 1634 ? Asking this because, we have a open ticket to track this issue. And we can not resolve our ticket unless this issue gets resolved. Thanks.

comment:5 Changed 4 years ago by Jakub Ś

You can't get any access to that issue. As I have said this is our internal bug tracker for our use only.

I can ask my colleagues to add information in our internal bug tracker to leave info here once internal ticket is closed.

Since this issue was confirmed for CKSource websites, could you tell me why do you even keep track of it? CKSource websites are not used in any of your products and I don't think your users visit it.
The only sites that your users might visit are SDK, docs and perhaps add-ons. Are there any particular websites that in your opinion should have this "feature"?

Changed 4 years ago by IBM_RQM

Attachment: CKEditor_Violation.png added

Violation reported on a page containing CK Editor

comment:6 Changed 4 years ago by IBM_RQM

We integrate CKEditor in our product to allow user to enter rich text content. This issue was reported on a page containing CKEditor. I can reproduce the issue on CKEditor demo site as well - http://ckeditor.com/demo Please check the attached screenshot (CKEditor_Violation.png​). Do you still think that, this is invalid issue ?

comment:7 Changed 4 years ago by Jakub Ś

This issue was reported on a page containing CKEditor.

I have never said that this is an invalid issue but our pages like demo page is not something that you will use inside your product thus it should not be such a big concern of yours. That is all what I was trying to say.

I don't think that it is even necessary that you track problem which concerns our websites.

Having said all the above, we will of course fix this issue.

Since you can't have access to our internal bug tracer, I can only offer that we will leave comment inside this ticket once we are done. I still don't think that it is necessary for you to track this issue as it doesn't concern CKEditor the wysiwyg editor.

comment:8 Changed 3 years ago by IBM RQM

Hi, is the associated defect in the internal bug tracer resolved ? If yes, in which release of CKEditor, we will get the fix for this issue ? Thanks.

comment:9 Changed 3 years ago by Jakub Ś

Yes it has. You can test it on http://ckeditor.com/features.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy