Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14450 closed Bug (invalid)

Font and Color picker is getting reset when user hits enter or clicks

Reported by: Chidanand Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. In CKEditor toolbar, select any Font from Font Family drop-down, Select any Text color and background color.
  2. Enter some Text, Check entered text shows all selected properties.

Refer Fig 1.

  1. Now hit Enter from Keyboard and enter some text.
  2. All selected properties are set to default. Refer Fig 2.

Expected result

Font and Color picker should not get reset when user hits enter or clicks in CKEditor.

Actual result

Font and Color picker is getting reset when user hits enter or clicks

Other details (browser, OS, CKEditor version, installed plugins)

Browser : Google Chrome,Mozilla Firefox, Internet Explorer

CKEditor version : 4.5.7

installed plugins : dragresize, imageresize

Attachments (3)

Fig 1.png (19.8 KB) - added by Chidanand 3 years ago.
Fig 2.png (20.4 KB) - added by Chidanand 3 years ago.
2016-03-03_1717.swf (550.7 KB) - added by Jakub Ś 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by Chidanand

Attachment: Fig 1.png added

Changed 3 years ago by Chidanand

Attachment: Fig 2.png added

Changed 3 years ago by Jakub Ś

Attachment: 2016-03-03_1717.swf added

comment:1 Changed 3 years ago by Jakub Ś

Status: newpending
Version: 4.5.7

I can't reproduce this problem.

Please see attached video - typing and pressing Enter seems to work without problems. The closest to what you have described, is covered by this ticket - #12634 (last line in the video)

We also have problems with block styles (starting from CKEditor 4.5.0) - #14250 but I can't seem to find a way to reproduce loosing inline styles.

Are you able to reproduce this in CKEditor demo? Perhaps you are using some CKEditor third-party plugin which is causing this?

comment:2 Changed 3 years ago by Chidanand

Thank you for the reply.

I forgot to add one of the step to reproduce and i apologize for that, we need to enable default spell check to reproduce this bug as you can see in "Fig 1.png".

comment:3 Changed 3 years ago by Chidanand

Que: Are you able to reproduce this in CKEditor demo? Perhaps you are using some CKEditor third-party plugin which is causing this?

Ans: Yes, i able to reproduce this in CKEditor demo and not the issue with third-party plugin.

comment:4 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

I can confirm this problem is happening in Chrome/Webkit browsers only when Scayt is turned on.

I have reported this issue to SCAYT team - https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/125 (@Chidanand, please refer to that ticket).

I'm closing this ticket as invalid for now.

comment:5 Changed 3 years ago by Chidanand

Ok fine and thank you again for the reply.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy