Opened 3 years ago

Closed 3 years ago

#14541 closed Bug (fixed)

Normalization does not normalize colors

Reported by: Tomasz Jakut Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: Cc:

Description

Steps to reproduce

  1. Open https://jsfiddle.net/Comandeer/42ja7gs3/
  2. Select some part of red text, e.g. r{em}ove.
  3. Click the empty button in the toolbar.

Expected result

The formatting (red color) is removed from the selected text.

Actual result

The formatting is not removed.

Other details (browser, OS, CKEditor version, installed plugins)

Function that is used to check if the style matches the selection (`compareCssText`) normalizes CSS on the target element, however our normalization method normalizes colors only when native normalization is used. It should always normalize them.

Change History (3)

comment:1 Changed 3 years ago by Tomasz Jakut

Status: newconfirmed

comment:2 Changed 3 years ago by kkrzton

There are two related issues: #14436 and #14252.

The #14252 is about specific problem which is caused by the issue with normalization you mentioned. It is in review state so maybe it may help speed up things a little if needed.

Not sure if this ticket shouldn't be marked as duplicate though.

comment:3 Changed 3 years ago by Tomasz Jakut

Resolution: fixed
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy