Opened 3 years ago

Closed 2 years ago

#14556 closed Bug (wontfix)

In Microsoft Edge/IE11 editor scroll to top if you click in beginning of a line

Reported by: Alf Georg Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.7
Keywords: Cc:

Description

Steps to reproduce

  1. Use Microsoft Edge 25.10586 and open the CKEditor demo
  2. Scroll down a bit and then click all to the left at beginning of a line

Expected result

The editor should stay in place

Actual result

The editor scrolls to top - every time

Other details (browser, OS, CKEditor version, installed plugins)

Microsoft Edge 25.10586 HTML 13.10.86, Windows 10.

Attachments (1)

zIvBqQXZWl.gif (1.2 MB) - added by Albert Jankowski 3 years ago.
Edge Scroll Up Issue

Download all attachments as: .zip

Change History (11)

comment:1 Changed 3 years ago by kkrzton

Status: newconfirmed

Confirmed for CKEditor 4.5.8 and Edge 20.10240.16384.0.

comment:2 Changed 3 years ago by Albert Jankowski

Version: 4.5.74.5.9

I am having the same issue on Microsoft Edge which makes it very difficult to pretty much unusable. Here is a video of it in action: http://g.recordit.co/zIvBqQXZWl.gif

Any way we can bump this up to High Priority?

I am testing on:

Microsoft Edge 25.10586.0.0

Microsoft EdgeHTML 13.10586

Last edited 3 years ago by Albert Jankowski (previous) (diff)

comment:3 Changed 3 years ago by Jakub Ś

Version: 4.5.94.5.7

The gif you have provided gives HTTP 403.

You say that this issue makes editor unusable but in reality how often do you click between editor border and text. I have been using the editor for 5 years now and know this isn't something I do every day.

Could you elaborate on that?


Please don't change the version number. It is used to show when problem has started occurring.

comment:4 Changed 3 years ago by Albert Jankowski

Can you try the gif again? It is still working for me. http://g.recordit.co/zIvBqQXZWl.gif

Perhaps I was wrong on saying that it isn't usable it is extremely difficult to use using the Microsoft Edge Browser.

Basically say you are writing some text and then you want to delete the first word so you click on the beginning of the line it just scrolls to the top.

comment:5 Changed 3 years ago by Jakub Ś

I'm still getting 403. You as the creator may have access to it but most likely no one else has it. You could try attaching this give to the ticket.

Your description however explains exactly what the problem is. In general in IE if the is no focus in editor, you scroll down and click between text/border, you will get scroll up effect. This happens in all browsers.

In IE11- if you click somewhere in editor, scroll down and click between text/border, cursor stays in previously clicked place.

In Edge when you click between text/border there is always scroll. It doesn't matter if there is focus in editor or not.

Changed 3 years ago by Albert Jankowski

Attachment: zIvBqQXZWl.gif added

Edge Scroll Up Issue

comment:6 Changed 3 years ago by Albert Jankowski

Weird I was able to see the 403 now. Here is the gif:

https://dev.ckeditor.com/attachment/ticket/14556/zIvBqQXZWl.gif

comment:7 Changed 2 years ago by Michael

Hey CKEdtior team, are there any plans to address this issue? It's been open for well over a year and many users are migrating or have migrated to Windows 10 now.

Thanks!

comment:8 Changed 2 years ago by Jakub Ś

Summary: In Microsoft Edge editor scroll to top if you click in beginning of a lineIn Microsoft Edge/IE11 editor scroll to top if you click in beginning of a line

I have checked this issue and it is still reproducible in IE11 and it has improved a bit in Edge 38.14393.1066.0. When you click at the beginning of the line, there is no scrolling however cursor is not being put at the point of click but at the start of the content area and when you start typing it scrolls up.

I will ask if there can be done anything about this issue.

comment:9 Changed 2 years ago by Jakub Ś

Ok, that was quick. This is browser issue. Please see: https://github.com/ckeditor/ckeditor-dev/issues/483.

comment:10 Changed 2 years ago by kkrzton

Resolution: wontfix
Status: confirmedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy