Opened 12 years ago

Closed 10 years ago

#1456 closed Bug (worksforme)

Cyrillic characters being corrputed

Reported by: Thomas Tallyce Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.3
Keywords: Pending WorksForMe Cc:

Description

If I paste in this text (or other similar text):

Методологиа

the outputted HTML is

МеÑ'одологиа

which appears online as

МеÑ'одологиа

Attachments (1)

cyrillic.patch (6.9 KB) - added by Mathieu Boillat 11 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by Martin Kou

Keywords: Pending added; language cyrillic russian removed

I wasn't able to reproduce the problem on the nighty build, so it might have been fixed in 2.5. Perhaps you could try again with the nighty build or the 2.5 beta and see if the bug still occurs?

comment:2 Changed 12 years ago by Thomas Tallyce

The 2.5 beta demo at /demo/ does indeed appear to fix this problem.

NB Using the nightly build link you've given results in a 405 METHOD NOT ALLOWED on http://www.fckeditor.net/nightly/fckeditor/_samples/html/sampleposteddata.asp

comment:3 Changed 12 years ago by Martin Kou

Resolution: fixed
Status: newclosed

I don't admin the www.fckeditor.net site but I guess that's just because the web server haven't been configured with ASP support.

Since the reported problem is no longer occurring in 2.5 beta, I'm closing this ticket.

comment:4 Changed 11 years ago by Thomas Tallyce

Does indeed appear to be fixed in 2.5. Very many thanks for this - excellent work as ever.

Changed 11 years ago by Mathieu Boillat

Attachment: cyrillic.patch added

comment:5 Changed 11 years ago by Mathieu Boillat

Resolution: fixed
Status: closedreopened
Version: FCKeditor 2.4.1FCKeditor 2.6.3

I got the same problems with the version 2.6.3 so I have created a patch that convert cyrillic and polish characters to HTML entities, like the latin and the greek alphabets.

Please find the patch attached.

comment:6 Changed 11 years ago by Artur Formella

Keywords: WorksForMe added

comment:7 Changed 10 years ago by Artur Formella

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy