Opened 12 years ago

Closed 8 years ago

Last modified 5 years ago

#1457 closed Bug (worksforme)

paste from word a 3-level list

Reported by: Hao Li Owned by:
Priority: Normal Milestone:
Component: Plugin : Paste from Word Version:
Keywords: Cc:

Description

if pasting from word a multi-level nested list, third level and above will be enclosed in a <div> and put out of the list.

please try the attached word file and do a paste from word. Please check both boxes "ignore..." and "remove style definitions".

Attachments (1)

list-test.doc (19.5 KB) - added by Hao Li 12 years ago.
multilevel nested list in word

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by Hao Li

Attachment: list-test.doc added

multilevel nested list in word

comment:1 Changed 12 years ago by Martin Kou

Keywords: Confirmed added
Priority: HighNormal

Confirmed for IE, Firefox and Safari. Opera doesn't seem to be able to receive HTML code from MS Word.

The problem seems to originate from MS Word, instead of from FCKeditor though. The way MS Word outputs the HTML code of the list items as <p> or <div> with lots of spaces and indentation looks like a fallback method in case it encounters a list type not supported by HTML lists, or in this case, a type that MS Word's programmers have not accounted for. For FCKeditor to fix this, it might have to parse MS Word's erratic HTML output, look for such misplaced lists, and rewrite the HTML code.

comment:2 Changed 8 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Pasting
Resolution: worksforme
Status: confirmedclosed

WFM with CKEditor 3.6 and probably with earlier versions as well.

comment:3 Changed 5 years ago by Frederico Caldeira Knabben

Component: Core : PastingPlugin : Paste from Word
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy