Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14561 closed Bug (invalid)

Upload Image Plugin - Multiple Images Pasted - Incorrect Image Name Used

Reported by: Keith Davis Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Paste multiple images at once (like from an email)

Expected result

Each image is uploaded and the placeholders are replaced with the correct image URL.

<img height="94" src="http://intranet.pridedallas.com:92/ticket_files/82864/image_003.png" width="348" />

<img height="137" src="http://intranet.pridedallas.com:92/ticket_files/82864/image_004.png" width="207" />

Actual result

Both images are uploaded, but the URLs are all replaced by the same one.

<img height="94" src="http://intranet.pridedallas.com:92/ticket_files/82864/image_003.png" width="348" />

<img height="137" src="http://intranet.pridedallas.com:92/ticket_files/82864/image_003.png" width="207" />

Other details (browser, OS, CKEditor version, installed plugins)

This appears to be some kind of AJAX async problem, as if enabled XDebug and break after each image upload, before the response is sent, the issue does not occur.

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: uploadimage removed
Resolution: invalid
Status: newclosed
Version: 4.5.6

I can't reproduce this issue. I have connected CKEditor with CKFinder and everything worked correctly when dropping multiple images.
I have tried different images, same size images with different names but all worked as expected. Correct names were sent and correct names were returned.

If you are able to reproduce this issue with CKEditor + CKFinder then please let me know but currently I think this problem is related to your server-side and will close it as invalid.
If you provide further details explaining why this is CKEditor issue, I will gladly reopen this ticket.

comment:2 Changed 3 years ago by Keith Davis

I was server side. I fixed it yesterday. The server code was finding a unique name for the file, but because that process was faster than the upload of the actual file, multiple images ended up with the same name.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy