Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#14568 closed Bug (invalid)

CKEditor read only in Explorer

Reported by: Joachim Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

I have setup a page https://thimbleprojects.org/calvinmcgee/50111/ with my issue.

I am setting toolbar config upon configLoaded.

Actual result

Toolbar is read only in Internet explorer.

Other information

Tested in IE11

Change History (5)

comment:1 Changed 4 years ago by Joachim

I saw an e-mail with an update in this ticket from @j.swiderski, but it's not visible here.

comment:2 Changed 4 years ago by Jakub Ś

I was an anser for some other ticket posted here by mistake. I will check this issue today.

comment:3 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.7

I have prepared basic sample with CKEDITOR.dtd.$editable.td = 1; and it won't work in IE11. We are not going to fix that however. Editables made on td are not supported. Please see issue #14568 for more details

@CalvinMcGee I would suggest that you put editable div inside td and build CKEditor on that div.
You could also thing about moving to HTML5. Your current table layout is very very old school.

comment:4 Changed 4 years ago by Joachim

Ok, I see. I want to note that I am fully capable of building HTML5 templates, however this is intended as HTML email templates. Sad to say, but HTML in email is very old school. This template is built upon well tested templates provided by the biggest ESP's.

comment:5 Changed 4 years ago by Jakub Ś

however this is intended as HTML email templates

Should have known this is for emails :).

Anyway even for such old template div in td should be perfectly fine and it should not break anything.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy