Opened 4 years ago

Closed 4 years ago

#14579 closed Bug (wontfix)

Incorrect special character encoding in Paste From Word Dialog in Firefox

Reported by: Frank Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Firefox Cc:

Description

Steps to reproduce

When i'm trying to paste text copied from Word document and containing special characters with font "Symbol" the dialog window that opens on click on "Paste from Word" button doesn't show the special characters like lamda, mu, copyright symbol, etc. correctly.

  1. I make a Word document with the sting containing special characters for "lambda mu" and copy this thext string.
  2. I can check the contents of my clipboard in Free Clipboard Viewer 3.0 in the Tab HTML Format. My clipboard then contains such code
<body lang=DE style='tab-interval:35.4pt'>
<!--StartFragment--><span lang=EN-US style='font-size:11.0pt;font-family:
Symbol;mso-ascii-font-family:Calibri;mso-ascii-theme-font:minor-latin;
mso-fareast-font-family:"Times New Roman";mso-hansi-font-family:Calibri;
mso-hansi-theme-font:minor-latin;mso-bidi-font-family:Calibri;mso-bidi-theme-font:
minor-latin;mso-ansi-language:EN-US;mso-fareast-language:EN-US;mso-bidi-language:
AR-SA;mso-char-type:symbol;mso-symbol-font-family:Symbol'><span
style='mso-char-type:symbol;mso-symbol-font-family:Symbol'>a</span></span><span
lang=EN-US style='font-size:11.0pt;font-family:Symbol;mso-ascii-font-family:
Calibri;mso-ascii-theme-font:minor-latin;mso-fareast-font-family:"Times New Roman";
mso-hansi-font-family:Calibri;mso-hansi-theme-font:minor-latin;mso-bidi-font-family:
Calibri;mso-bidi-theme-font:minor-latin;mso-ansi-language:EN-US;mso-fareast-language:
EN-US;mso-bidi-language:AR-SA;mso-char-type:symbol;mso-symbol-font-family:Symbol'><span
style='mso-char-type:symbol;mso-symbol-font-family:Symbol'>m</span></span><!--EndFragment-->
</body>

  1. I click the "Paste from Word" button in the CKEditor on the http://ckeditor.com/demo and paste the contents of my clipboard into the opend dialog.

Expected result

the symbols lambda and mu are shown as symbols, exactly as in the Word document.

Actual result

in Chrome: the symbols lambda and mu are shown as symbols, exactly as in the Word document.

in Firefox:

the sting "am" is pasted into the dialog

Other details (browser, OS, CKEditor version, installed plugins)

Attachments (1)

The Risk of (1).docx (13.3 KB) - added by Frank 4 years ago.
Some Word document that with incorrect character encoding

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by Frank

Attachment: The Risk of (1).docx added

Some Word document that with incorrect character encoding

comment:1 Changed 4 years ago by Frank

In the attached Word document you can see some longer text containing the special characters that are not correctly pasted on copy paste in Firefox

comment:2 Changed 4 years ago by Jakub Ś

Keywords: Firefox added; Paste From Word removed
Resolution: wontfix
Status: newclosed
Version: 4.5.7

After settig both of these properties to false:
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-pasteFromWordRemoveFontStyles
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-pasteFromWordRemoveStyles
Issuem seems to be gone in Chrome and IE but not Firefox.

The problem is that the same tendence can be observed in native contenteditable iframe or any contenteditable element for that matter. When you paste your sample text into Chrome or IE editable element it gest displayed properly but in Firefox you can see standard 'a' characters.

From what I can see Firefox removes some of the styles and doesn't seem to understand them (I have tried pasing them manually but that didn't change ‘a’ to lambda like in Chrome for example). I'm sorry but this is a "won't fix" for us if Firefox can't understand these styels.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy