Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#14594 closed Bug (wontfix)

enterMode=ENTER_BR setting breaks IE10 behavior

Reported by: jamadam Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE10 Cc:

Description

Steps to reproduce

  1. Open sample (samples/index.html)
  2. Run following code with developer tools console in IE10 to reset the setting.
    CKEDITOR.instances['editor'].destroy();
    CKEDITOR.replace('editor', {enterMode: CKEDITOR.ENTER_BR});
    
  3. Empty the editor area then click 'horuzontalrule' button.

Expected result

A Line is drawn and cursor is located right after it.

Actual result

A Line is drawn and cursor is on top of it.

Other details (browser, OS, CKEditor version, installed plugins)

IE10, CKEditor 4.5.7. It dosn't happen with IE11 or Firefox.

Change History (9)

comment:1 Changed 4 years ago by jamadam

needsBrFiller seems to have something to do with it. (#10907)

comment:2 Changed 4 years ago by Jakub Ś

Keywords: IE10 added
Resolution: wontfix
Status: newclosed
Version: 4.5.9 (GitHub - master)
  1. CKEditor is not responsible for rendering the cursor.
  2. If you start typing letters will be entered correctly after the hr
  3. The same thing can be reproduced in native contenteditable iframe with only hr element inside it.

comment:3 Changed 4 years ago by jamadam

Note that CKE3 on IE10 used to work fine, guessing because it puts <p> after <hr> no matter the enterMode is.

And arround hr there still is a problem.

Steps to reproduce

  1. Open sample (samples/index.html) setting enterMode to CKEDITOR.ENTER_BR
  2. Empty the editor and click horizontalrule button
  3. Hit right key on keyboard.

Expected result

Except actual result.

Actual result

Cursor is located inside hr.

Other details (browser, OS, CKEditor version, installed plugins)

This can't be reproduced on CKE3 but similar problem could happen with defferent steps. Also on CKE4, after inserting hr, by clicking editor area, the focus would be lost until source to be manualy fixed.

Last edited 4 years ago by jamadam (previous) (diff)

comment:4 Changed 4 years ago by Jakub Ś

Note that CKE3 on IE10 used to work fine, guessing because it puts <p> after <hr> no matter the enterMode is.

Yes, but it was incorrect to put extra P into editor contentarea when use has set enter mode to BR and wanted to insert just the HR (without extra P).

Hit right key on keyboard.

And the same can be reproduced in native contenteditable but if you start typing text will be displayed directly under the HR. There is another issue and it can be reproduced in IE10 as well. Try to delete characters typed under HR - one will always be left and this is also IE10 issue. I'm sorry but all you are seeing are IE bugs and there is nothing we can do here.


Please also note that this problem doesn't occur when you use enter mode set to P which is recommended by CKEditor team. Many users use BR because lines are so "small" but you can get same result by setting margin:0 on paragraphs. All you is enter such rule into contents.css

p {margin : 0;}

Same rule should be used on target page where this content will be used.

I'm not sure if BR mode is actual requirement in your application or it was used because just of "small lines" I have described above but I would strongly recommend switching to P

comment:5 Changed 4 years ago by jamadam

Thanks for the suggestion. I would consider switching to ENTER_P. And I appreciate your effort to maintain numerous UA specific workarrounds.

comment:6 Changed 3 years ago by jamadam

Hi again.

In the original post, replacing the procedure 3 as follows

  1. Empty the editor area then click 'horuzontalrule' button and click editor area.

cuases following javascript error.

Unable to get property 'ownerDocument' of undefined or null reference selection.js, line 779 character 5

It this also "won't fix" ?

[EDIT] ckeditor 4.5.8 and IE10

Last edited 3 years ago by jamadam (previous) (diff)

comment:7 Changed 3 years ago by Jakub Ś

@jamadam I have just tried CKEditor 4.5.8-4.5.11 on IE10 and it works as expected. NO error is thrown with that test case.

Could you perhaps explain in more detail, what needs to be done to reproduce this issue?

comment:8 Changed 3 years ago by jamadam

Thanks.

I double checked on clean CKEditor 4.5.11 and modernIE instance of IE10 on win7.

SCRIPT5007: Unable to get property 'ownerDocument' of undefined or null reference 
selection.js, line 788 character 5

Note that the error is only reported on developer console unless the IE option "Display a notification about every script error" is checked.

comment:9 Changed 3 years ago by Jakub Ś

@jamadam - sorry for late reply. I was able to confirm the ticket and have reported it here: #16820.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy