Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1462 closed Bug (fixed)

Safari: Main window scrolls on enter

Reported by: Alexander Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: Safari Compatibility
Component: UI : Enter Key Version: FCKeditor 2.5 Beta
Keywords: Confirmed Safari Cc: ayuganov@…

Description

When I enter new paragraph Safari moves to the beginning of the page. See attached video.

Attachments (1)

tc.html (2.2 KB) - added by Frederico Caldeira Knabben 10 years ago.
TC

Download all attachments as: .zip

Change History (11)

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Enter Key
Keywords: Confirmed Safari added
Milestone: Safari Compatibility

Confirmed. It seems like a big bug in WebKit.

I'll be attaching a TC for it.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: tc.html added

TC

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Priority: NormalHigh
Summary: Safari: New paragraphSafari: Main window scrolls on enter

comment:4 Changed 10 years ago by Frederico Caldeira Knabben

The TC is reachable here:
http://www.fckeditor.net/_temp/browsers_bugs/safari/1462.html

The Reduced TC instead can be found here instead:
http://www.fredck.com/bugs/safari/1462_reduced.html

comment:5 Changed 10 years ago by Frederico Caldeira Knabben

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

We have this problem because we are using scrollIntoView(false).

We could avoid using it if WebKit would automatically scroll the view to ensure that the caret is always visible, like IE does, but it doesn't support it. This need has been reported to WebKit too:
http://bugs.webkit.org/show_bug.cgi?id=16118

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Status: newassigned

comment:9 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [1124]. Click here for more info about our SVN system.

I've introduced a custom implementation for scrollIntoView that fits our needs. I still hope WebKit will bring the definitive solution in any case.

comment:10 Changed 10 years ago by Frederico Caldeira Knabben

[1124] was not working properly when inside blockquotes or lists. Fixed with [1143].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy