Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14620 closed Bug (fixed)

Autogrow plugin should reset iframe's html height

Reported by: Marek Lewandowski Owned by: kkrzton
Priority: Normal Milestone: CKEditor 4.5.9
Component: General Version:
Keywords: Cc:

Description (last modified by kkrzton)

This issue comes from https://www.drupal.org/node/2239419.

What happens there is that D8 is overriding min-height attribute for body element which with connection to height: 100% for html breaks the autogrow plugin.

To prevent that we could set body's element min-height (and probably height) to auto in initIframeAutogrow and it should work just fine. Note that it cannot be solved by setting html's element height to auto due to gecko wyswigarea plugin fix.

You'll find some useful findings here https://www.drupal.org/node/2239419#comment-10906692.

Change History (6)

comment:1 Changed 2 years ago by Marek Lewandowski

Status: newconfirmed

comment:2 Changed 2 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:3 Changed 2 years ago by kkrzton

Description: modified (diff)

comment:4 Changed 2 years ago by kkrzton

Status: assignedreview

Pushed changes to t/14620.

comment:5 Changed 2 years ago by Tade0

Resolution: fixed
Status: reviewclosed

comment:6 Changed 2 years ago by Anna Tomanek

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy