Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14695 closed Bug (invalid)

CKEditor maximize plugin issue

Reported by: sravani Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Click on the ckeditor maximize button.
  2. Resize the window.
  3. click on the same ckeditor button to minimize.

Expected result

When we go back to minimize mode the ckeditor should fit to the resized browser window.

Actual result

ckeditor resizing to size the of the window before resizing the browser. This issue can reproduce only when we do resize the browser in the ckeditor maximize mode

Other details (browser, OS, CKEditor version, installed plugins)

reproducible in all browsers. OS:windows 7. version:ckeditor 4.3.3

Change History (3)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.7

In CKEditor samples body has fixed width of 960px. When you minimize browser window, body still has 960px and editor fills all that space. Changing body width to auto has solved this problem.

comment:2 Changed 3 years ago by sravani

Can you please guide where exactly i need to change the the ckeditor body to auto.Because I tried to changing that it's not working. In the maximize plugin.js restoring the styles that are saved when going to ckeditor maximize mode.Actually this styles are saved before browser resize.

comment:3 Changed 3 years ago by Jakub Ś

In CKEditor samples body has fixed width of 960px where exactly i need to change the the ckeditor body to auto.

This wasn't CKEditor body but main page body element. Please go to ckeditor/samples/old/replacebycopde.html. Open it in a browser, change body width (using dev-tools to auto) and you will see.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy