Opened 3 years ago

Closed 3 years ago

#14696 closed Bug (duplicate)

BBCode Plugin doesn't preserve seperate paragraphs of text - Merges into 1x para

Reported by: Alan Howshall Owned by:
Priority: Normal Milestone:
Component: General Version: 3.6
Keywords: Cc:

Description

Steps to reproduce

  1. Go to CKEditor standard demo http://ckeditor.com/demo and copy 2x 'Apollo 11' paragraphs of text into clipboard.
  2. Go to CKEditor BBCode demo http://sdk.ckeditor.com/samples/bbcode.html and delete all existing sample content then paste 2x copied 'Apollo 11' paragraphs of text.
  3. Toggle into and out of BBCode Demo 'Source' view mode.

Expected result

Once pasted it should be possible to toggle into and out of 'Source' view mode maintaining visually separate paragraphs of text. And having separate paragraphs of text submitted back to server.

Actual result

While initially pasted WSYWIG result looks okay (i.e. Text still as 2x separate paragraphs) As soon as you toggle into and out of 'Source' view mode you will see that separate paragraph text becomes merged as 1x block of text. That same merging of text paragraphs is also present in source code submitted back to the server.

The reason for this is HTML source <P> tags are being stripped by BBCode and </P> tag is not being replaced with 2x Line Breaks instead, which would then preserve intended paragraphs separation and nearest equivalence possible with BBCode.

Other details (browser, OS, CKEditor version, installed plugins)

Same behaviour in IE11, Firefox and Chrome on Windows 8.1 CKEditor v4.5.9 with BBCode plugin

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: BBCode removed
Resolution: duplicate
Status: newclosed
Version: 4.5.10 (GitHub - master)3.6

This issue is in fact a duplicate of #7870.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy